[FIX] account_asset: depreciation entries not correct #15006

Closed
wants to merge 1 commit into
from

Projects

None yet

2 participants

@simongoffin
Contributor
simongoffin commented Jan 10, 2017 edited

Steps to reproduce:

  • create an asset type with the depreciation asset account set as 100000 Fixed Asset Account
    and with the depreciation expense account set as 212100 Salary Expenses.
  • create an asset from scratch in Accounting > Adviser > Assets for a gross value of a 100
  • confirm the asset
  • click on the red button on the first depreciation line
  • take a look at the depreciation journal entry: you'll see that it debits the Depreciation Asset Account
    and it credits the Depreciation Expense Account

Expected Behavior: in the accounting entry of the asset, it is the Depreciation Asset Account which should
be credited and the Depreciation Expense Account which should be debited.

The expected behavior is the behavior of SaaS 11.

opw:703860

@simongoffin simongoffin [FIX] account_asset: depreciation entries not correct
Steps to reproduce:
- create an asset type with the depreciation asset account set as 100000 Fixed Asset Account
and with the depreciation expense account set as 212100 Salary Expenses.
- create an asset from scratch in Accounting > Adviser > Assets for a gross value of a 100
- confirm the asset
- click on the red button on the first depreciation line
- take a look at the depreciation journal entry: you'll see that it debits the Depreciation Asset Account
and it credits the Depreciation Expense Account

Expected Behavior: in the accounting entry of the asset, it is the Depreciation Asset Account which should
be credited and the Depreciation Expense Account which should be debited.

The expected behavior is the behavior of SaaS 11.

opw:703860
2182c8d
@C3POdoo C3POdoo added the OE label Jan 11, 2017
@simongoffin
Contributor

Closed with 342dad4 and f98a4d4

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment