New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Missing File: logging_default.ini #235

Closed
fwitte opened this Issue Nov 2, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@fwitte
Copy link
Member

fwitte commented Nov 2, 2016

I've just installed the recent version of oemof on ubuntu 16.04 via terminal (pip3 install oemof), the following error appeared while running the simple_least_costs example:

Traceback (most recent call last):
File "beispiel.py", line 177, in
run_simple_least_costs_example()
File "beispiel.py", line 169, in run_simple_least_costs_example
logger.define_logging()
File "/home/francesco/.local/lib/python3.5/site-packages/oemof/tools/logger.py", line 62, in define_logging
shutil.copyfile(default_file, log_filename)
File "/usr/lib/python3.5/shutil.py", line 114, in copyfile
with open(src, 'rb') as fsrc:
FileNotFoundError: [Errno 2] No such file or directory: '/home/francesco/.local/lib/python3.5/site-packages/oemof/tools/default_files/logging_default.ini'

Any idea, how to fix that?

@uvchik

This comment has been minimized.

Copy link
Member

uvchik commented Nov 2, 2016

A quick fix is to copy the content of the following link to '/home/francesco/.oemof/logging.ini.

https://raw.githubusercontent.com/oemof/oemof/dev/oemof/tools/default_files/logging_default.ini

I will see, if I find the reason for this error.

@uvchik uvchik added the bug label Nov 2, 2016

@uvchik uvchik self-assigned this Nov 2, 2016

@ckaldemeyer

This comment has been minimized.

Copy link
Member

ckaldemeyer commented Nov 2, 2016

He says it has been fixed with your workarround!

uvchik added a commit that referenced this issue Nov 2, 2016

fix execution_of_examples after installation #236
If you install a clean oemof (v0.1) the execution of the example fails due to two reasons

* Matplotlib is missing, even though we decided to add matplotlib to the requirements we did not do it.
* logging.ini is not created because the default_logging.ini is not copied to the site-packages (s. #235)
@uvchik

This comment has been minimized.

Copy link
Member

uvchik commented Nov 2, 2016

The fix will be in PR #236.

@uvchik uvchik closed this Nov 2, 2016

@uvchik uvchik added this to the v0.1.1 milestone Nov 2, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment