Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

libcurl4 and php7.3-curl #1193

Closed
Yivan opened this issue Jun 17, 2019 · 4 comments
Closed

libcurl4 and php7.3-curl #1193

Yivan opened this issue Jun 17, 2019 · 4 comments

Comments

@Yivan
Copy link

@Yivan Yivan commented Jun 17, 2019

Hello,

First thanks a lot for providing this repository.

I would like to report a problem with php7.3-curl on debian buster.
Using deb.sury.org to install php7.3 on debian buster work fine, excepted for php7.3-curl.

I get:

The following packages have unmet dependencies:
 php7.3-curl : Depends: libcurl3 (>= 7.44.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

I saw this problem was existing in this issue for php7.2-curl: #831

Debian buster has only libcurl4. There is no possibility to install libcurl3. Trying apt-get install libcurl3 send:

Package libcurl3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libcurl4

E: Package 'libcurl3' has no installation candidate

So i have try to install libcurl4 with apt-get install libcurl4, install went fine, but always the same message when trying to install php7.3-curl.

How can the problem be handled ?
(i don't want to use native php7.3 from buster)

For information, apt policy php7.3-curl return:

php7.3-curl:
  Installed: (none)
  Candidate: 7.3.6-1+0~20190531112735.39+stretch~1.gbp6131b7
  Version table:
     7.3.6-1+0~20190531112735.39+stretch~1.gbp6131b7 500
        500 https://packages.sury.org/php stretch/main amd64 Packages
     7.3.4-2 500
        500 http://deb.debian.org/debian buster/main amd64 Packages

Thanks.

@todeveni

This comment has been minimized.

Copy link
Contributor

@todeveni todeveni commented Jun 17, 2019

You're using stretch packages in buster. That might be a problem.

@Yivan

This comment has been minimized.

Copy link
Author

@Yivan Yivan commented Jun 17, 2019

@todeveni Thanks, you are totaly right, i forgot to change it when adding the repo ( good version is now: sh -c 'echo "deb https://packages.sury.org/php/ buster main" > /etc/apt/sources.list.d/php.list').
All is ok now.

Thanks!
I close this issue.

@Yivan Yivan closed this Jun 17, 2019
@Adambean

This comment has been minimized.

Copy link

@Adambean Adambean commented Jul 19, 2019

That was a quick search for me too. I had upgraded Stretch to Buster in place, just needed to do sed -i /etc/apt/sources.list.d/php.list -e 's/stretch/buster/g', then apt update/upgrade again.

@rafaelricardo-rj

This comment has been minimized.

Copy link

@rafaelricardo-rj rafaelricardo-rj commented Nov 21, 2019

It helped me a lot guys! Thanks a million!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.