Browse files

fixing an error in the previous patch that broke the antlr4ruby scrip…

…t for regular windows users
  • Loading branch information...
1 parent 4c18507 commit d275287f8a5324c40b0f74f54912cc6a67743376 Kyle Yetter committed Apr 14, 2011
Showing with 4 additions and 4 deletions.
  1. +1 −1 bin/antlr4ruby
  2. +1 −1 config/antlr3.yaml
  3. +1 −1 lib/antlr3/version.rb
  4. +1 −1 templates/Ruby.stg
View
2 bin/antlr4ruby
@@ -83,7 +83,7 @@ jar = ANTLR3.antlr_jar or fail( "cannot find antlr4ruby's customized ANTLR jar"
# Convert the Posix path to a proper Windows path, otherwise the Java runtime
# will not find the antlr Jar file.
# -- Thanks to Marco Soeima for this fix
-if /mswin32|cygwin|mingw|bccwin/ =~ RUBY_PLATFORM
+if /cygwin/i =~ RUBY_PLATFORM
jar = `cygpath -aw #{jar}`.strip
end
View
2 config/antlr3.yaml
@@ -3,7 +3,7 @@
# project meta-data used for various project tasks like building gem packages
#
name: antlr3
-version: "1.8.11"
+version: "1.8.12"
antlr_version: "3.2.1"
summary: |-
View
2 lib/antlr3/version.rb
@@ -20,7 +20,7 @@ module ANTLR3
#
MAJOR_VERSION = 1
MINOR_VERSION = 8
- PATCH_VERSION = 11
+ PATCH_VERSION = 12
VERSION = [ MAJOR_VERSION, MINOR_VERSION, PATCH_VERSION ]
VERSION_STRING = VERSION.join( '.' ).freeze
View
2 templates/Ruby.stg
@@ -1459,4 +1459,4 @@ placeAction(scope, name) ::= <<
<endif>
>>
-runtimeLibraryVersion() ::= "1.8.11"
+runtimeLibraryVersion() ::= "1.8.12"

0 comments on commit d275287

Please sign in to comment.