Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

All screenshots are black on GNOME 3.22 #257

Open
NighTurs opened this issue Dec 25, 2016 · 7 comments
Open

All screenshots are black on GNOME 3.22 #257

NighTurs opened this issue Dec 25, 2016 · 7 comments

Comments

@NighTurs
Copy link

@NighTurs NighTurs commented Dec 25, 2016

All screenshots I make are black screens, totally unusable. Seems like it is related to GNOME using wayland by default since 3.22.

In logs I see following "org.gnome.Shell.desktop[763]: Window manager warning: Invalid WM_TRANSIENT_FOR window 0xa00007 specified for 0xa0001c (ScreenClou)."

Manjaro linux
Gnome 3.22
screencloud 1.3.1

@olav-st
Copy link
Owner

@olav-st olav-st commented Dec 26, 2016

Are you using Wayland?

@NighTurs
Copy link
Author

@NighTurs NighTurs commented Dec 26, 2016

I do. I guess regular X apps go through XWayland, can be because of XWayland bug.. not sure.

https://aur.archlinux.org/packages/screencloud, @tate here describes the same problem.

@lamehost
Copy link

@lamehost lamehost commented Aug 25, 2017

Any updates?
This blog post says you can get rid of the issue by disabling Wayland GTK+ backend throug the GDM config, but i can't find how.

Also, that would be a temporary fix, is there any plan to add Wayland support?

@NighTurs
Copy link
Author

@NighTurs NighTurs commented Aug 25, 2017

@lamehost I believe guy from blog post just switched back to Xorg, you can follow instructions in arch wiki.

@lamehost
Copy link

@lamehost lamehost commented Aug 31, 2017

@NighTurs thanks.
For the records: it works.

Anyway i am more interested in getting Screencloud working on Wayland.
Are there any plans?

Thank you

@jasonkuehl
Copy link

@jasonkuehl jasonkuehl commented Nov 29, 2017

I also have this issues

env | grep -i wayland
DESKTOP_SESSION=gnome-wayland
WAYLAND_DISPLAY=wayland-0
XDG_SESSION_TYPE=wayland
XDG_SESSION_DESKTOP=gnome-wayland
GDMSESSION=gnome-wayland

@camlafit
Copy link

@camlafit camlafit commented Mar 30, 2020

Hello

Problem look always occur. Any new about this bug ?

Thanks a lot :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants