Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

published to npm

  • Loading branch information...
commit b49218d1ba680bd6d244c7e69444eff0fc0b734d 1 parent d94b7f4
@olegp authored
Showing with 6 additions and 13 deletions.
  1. +3 −11 README.md
  2. +3 −2 package.json
View
14 README.md
@@ -23,23 +23,15 @@ The following modules are included:
### Installation
-If you don't already have them, [install Node version 0.5.0 or later](https://github.com/joyent/node/wiki/Installation) and the [Node Package Manager npm](http://npmjs.org):
+If you don't already have them, [install Node version 0.5.0 or later](https://github.com/joyent/node/wiki/Installation) (for Node 0.4.X check out the v0.4 branch of Common Node) and [Node Package Manager](http://npmjs.org). Install `common-node` as a global package:
- curl http://npmjs.org/install.sh | sh
-
-Clone the repository (an npm package will be made available once we have a stable release):
-
- git clone git://github.com/olegp/common-node.git
-
-To install `node-fibers` & `common-node` as global packages:
-
- sudo npm -g install fibers common-node
+ sudo npm -g install common-node
Run the "Hello World" example:
common-node common-node/examples/hello.js
-To test that it's working, make an HTTP request from another prompt:
+You shouldn't see any output. To test that it's working, make an HTTP request from another prompt:
curl http://localhost:8080/
View
5 package.json
@@ -1,5 +1,6 @@
{
"name": "common-node",
+ "keywords": ["commonjs"],
"description": "Synchronous CommonJS compatibility layer using node-fibers",
"version": "0.2.0",
"author": "Oleg Podsechin <oleg@ionsquare.com>",
@@ -13,7 +14,7 @@
},
"main": "./lib/all.js",
"bin": { "common-node": "./bin/common-node" },
- "engines": { "node": ">= 0.5.0" },
- "dependencies" : { "fibers": ">=0.6.1" },
+ "engines": { "node": ">= 0.5.2" },
+ "dependencies" : { "fibers": ">= 0.6.1" },
"preferGlobal": true
}
Please sign in to comment.
Something went wrong with that request. Please try again.