Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

mongo-sync failing with latest version of fibre(1.0.0) #8

Closed
sankalpsaxena81 opened this Issue · 5 comments

2 participants

@sankalpsaxena81

mongo-sync was working properly with fibre version 0.6.9

@olegp
Owner

@sankalpsaxena81 thanks for reporting this, will look into it within the next 24 hours

@olegp
Owner

@sankalpsaxena81 if you provided a stack trace and simple test case, that may speed things up

@sankalpsaxena81

The following line fails:
var Server = require("mongo-sync").Server;

Following is the stack trace :

ReferenceError: Fiber is not defined
at Object. (/Users/Thoughtworks/final-merchpay/merchpay/migrations/node_modules/mongo-sync/lib/mongo-sync.js:1:67)
at Module._compile (module.js:446:26)
at Object..js (module.js:464:10)
at Module. (module.js:353:31)
at Module.load (/usr/local/lib/node_modules/common-node/lib/run.js:44:22)
at Function._load (module.js:311:12)
at Module. (module.js:359:17)
at Module.require (/usr/local/lib/node_modules/common-node/lib/run.js:35:66)
at require (module.js:375:17)

@olegp olegp closed this issue from a commit
@olegp closes #8 8e5057a
@olegp olegp closed this in 8e5057a
@sankalpsaxena81

It works now.
Thanks Oleg !!

@olegp
Owner
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.