Compatibility with node 0.4.x #1

Closed
sergeyksv opened this Issue Mar 18, 2012 · 2 comments

Projects

None yet

2 participants

@sergeyksv
Contributor

Hi, I saw that package.json list minimal node version as 0.5.1. Is it by purpose? We tested it on 0.4.x and it seems to work fine.
Can you consider to adopt it for 0.4.x?
We still use 0.4.x branch because some critical for us modules with native code (like v8-profiler) still not work on 0.6.x.

@oleics
Owner
oleics commented Mar 18, 2012

Hi,

reason was that 'fork' of the child_process-module was introduced with node v0.5.1.

As long as the fork-option is not true, 'spawn' will be used, so it works for 0.4.x.

I'll set the version to 0.4.x and document the reason.

Greetings

@oleics oleics closed this in 56cdf95 Mar 18, 2012
@sergeyksv
Contributor

Thanks a lot, added dependancy to tinyhook from tinyforever. Original forever was tremendously huge and brings lot of xtra dependencies.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment