Permalink
Browse files

add FREETZ_AVM_HAS_AR7CFG_V12_MIN for avm-firewall/-forwarding (close…

…s #2226)

git-svn-id: file:///var/svn/freetz/trunk@11509 149334a1-2f27-0410-a3b9-fc62619ac1e6
  • Loading branch information...
1 parent dab40e6 commit 1821fe5d6586f826ad1ac4f8862c91519993826f cuma committed Dec 31, 2013
Showing with 19 additions and 3 deletions.
  1. +16 −0 Config.in.avm
  2. +1 −1 make/avm-firewall/Config.in
  3. +2 −2 make/avm-forwarding/Config.in
View
@@ -312,6 +312,22 @@ config FREETZ_AVM_GCC_4_7
###
+config FREETZ_AVM_HAS_AR7CFG_V12_MIN
+ bool "Has ar7.cfg version 12 minimum" if FREETZ_TYPE_CUSTOM
+ default y if \
+ FREETZ_AVM_VERSION_06_XX_MIN || \
+ FREETZ_AVM_VERSION_05_5X && ( \
+ FREETZ_TYPE_6810 || \
+ FREETZ_TYPE_6840 || \
+ FREETZ_TYPE_7272 || \
+ FREETZ_TYPE_7490 \
+ )
+ default n
+ help
+ Select this if your ar7.cfg is at least version 12.
+ In your ar7.cfg is a line like 'ar7cfg_version = x;'
+ Used by AVM-firewall/-forwarding
+
config FREETZ_AVM_HAS_PRINTK
bool "Has AVM printk support" if FREETZ_TYPE_CUSTOM
default y if \
@@ -1,6 +1,6 @@
config FREETZ_PACKAGE_AVM_FIREWALL
bool "AVM-firewall 2.0.4_rc5"
- depends on !FREETZ_REMOVE_DSLD && !FREETZ_AVM_VERSION_06_XX_MIN
+ depends on !FREETZ_REMOVE_DSLD && !FREETZ_AVM_HAS_AR7CFG_V12_MIN
default n
help
@@ -1,6 +1,6 @@
config FREETZ_PACKAGE_AVM_FORWARDING
- bool "AVM-forwarding for firmwares xx.05.55 or higher - EXPERIMENTAL"
- depends on !FREETZ_REMOVE_DSLD && FREETZ_AVM_VERSION_05_5X_MIN && FREETZ_SHOW_EXPERT
+ bool "AVM-forwarding 0.0.1a - EXPERIMENTAL"
+ depends on !FREETZ_REMOVE_DSLD && FREETZ_AVM_HAS_AR7CFG_V12_MIN
default n
help
Configuration of forwardings to FB itself (open ports).

0 comments on commit 1821fe5

Please sign in to comment.