Skip to content
This repository
Newer
Older
100644 48 lines (41 sloc) 1.776 kb
d5e74980 »
2011-01-04 setup.py updated
1 # -*- coding: utf-8 -*-
2 """Setup file for easy installation"""
3 from os.path import join, dirname
4 from setuptools import setup
df298770 » Stas Kravets
2010-12-27 setup.py file added for correct install with pip
5
d5e74980 »
2011-01-04 setup.py updated
6
0b9ad8c8 »
2011-01-05 Updated setup.py file to install properly, added version to social_au…
7 version = __import__('social_auth').__version__
8
9 LONG_DESCRIPTION = """
10 Django Social Auth is an easy to setup social authentication/registration
11 mechanism for Django projects.
12
13 Crafted using base code from django-twitter-oauth_ and django-openid-auth_,
14 implements a common interface to define new authentication providers from
15 third parties.
16 """
17
18 def long_description():
19 """Return long description from README.rst if it's present
20 because it doesn't get installed."""
21 try:
22 return open(join(dirname(__file__), 'README.rst')).read()
23 except IOError:
24 return LONG_DESCRIPTION
25
26
d5e74980 »
2011-01-04 setup.py updated
27 setup(name='django-social-auth',
0b9ad8c8 »
2011-01-05 Updated setup.py file to install properly, added version to social_au…
28 version=version,
d5e74980 »
2011-01-04 setup.py updated
29 author='Matías Aguirre',
30 author_email='matiasaguirre@gmail.com',
31 description='Django social authentication made simple.',
32 license='GPL',
33 keywords='django, openid, oath, social auth, application',
34 url='https://github.com/omab/django-social-auth',
35 packages=['social_auth'],
0b9ad8c8 »
2011-01-05 Updated setup.py file to install properly, added version to social_au…
36 long_description=long_description(),
37 install_requires=['django>=1.2',
38 'oauth>=1.0',
39 'python_openid>=2.2'],
d5e74980 »
2011-01-04 setup.py updated
40 classifiers=['Framework :: Django',
41 'Development Status :: 4 - Beta',
42 'Topic :: Internet',
43 'License :: OSI Approved :: GNU General Public License (GPL)',
44 'Intended Audience :: Developers',
45 'Environment :: Web Environment',
0b9ad8c8 »
2011-01-05 Updated setup.py file to install properly, added version to social_au…
46 'Programming Language :: Python :: 2.5',
47 'Programming Language :: Python :: 2.6',
48 'Programming Language :: Python :: 2.7'])
Something went wrong with that request. Please try again.