New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

TreeModel.remove() doesnt remove current node #414

Closed
Patrizia218 opened this Issue Nov 9, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@Patrizia218

Patrizia218 commented Nov 9, 2017

TreeModel.remove() doesnt remove current node as expected but always removes first node from parents children.
I think its something with AbstractTreeModels equals method.
... L228 return equals(getRoot(this), getRoot((AbstractTreeModel)object)); always returns true for the first entry of the list as it has the same parent/root as the current node I want to remove.

This issue came with update to omnifaces 2.6.5. With 2.6.4 TreeModel.remove() worked as expected

@BalusC

This comment has been minimized.

Show comment
Hide comment
@BalusC

BalusC Nov 10, 2017

Member

That was a bad move. I have fixed it and added an unit test on it.

Thanks for reporting, it will be with next 2.6.6-SNAPSHOT.

Member

BalusC commented Nov 10, 2017

That was a bad move. I have fixed it and added an unit test on it.

Thanks for reporting, it will be with next 2.6.6-SNAPSHOT.

@BalusC BalusC closed this Nov 10, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment