Skip to content
This repository

This page summarizes some of the RubyGems (using native C-based extensions) various community members have found to be compatible with RubyInstaller-based Ruby environments using the MSys/MinGW based Development Kit (DevKit). Both the RubyInstaller and DevKit are available for download at rubyinstaller.org

If you have good experiences with other RubyGems in a RubyInstaller environment, we love to hear about it! Please let us know by adding an entry to the following summary tables.

If you find that a specific RubyGem doesn’t work, please drop us a line on the mailing list before updating the summaries. We may just be able to help you solve the issue, or help confirm that it’s a real issue.

Thanks!
The RubyInstaller Team

 RubyInstaller 1.9.1p243

Date Gem Version RubyGems DevKit* OS Status Notes
7/6/09 MySQL 5.0.83 1.3.4 NA Windows XP/7 OK x86-mingw32 gem works, source install is possible, see tutorials for links,
7/15/09 json 1.1.7 1.3.5 3.4.5r3 XP OK
8/17/09 yajl-ruby 0.5.12 1.3.5 4.3.3 WinXP Prof OK built via TDM-GCC
8/17/09 sqlite3-ruby 1.2.5 1.3.5 4.3.3 WinXP Prof OK built via TDM-GCC
9/14/09 sqlite3-ruby 1.2.5 1.3.5 NA Vista Home Premium OK x86-mingw32 binary gem
12/11/09 nokogiri 1.4.1 1.3.5 NA Vista Home Premium OK x86-mingw32 binary gem
10/26/09 eventmachine 0.12.10 1.3.5 3.4.5r3 WinXP Prof OK
10/26/09 thin 1.2.5 1.3.5 3.4.5r3 WinXP Prof OK
7/17/09 RedCloth 4.2.2 1.3.4 3.4.5r3 WinXP Home OK
12/9/09 ffi 0.5.4 1.3.5 NA Vista Home Premium OK x86-mingw32 binary gem
8/27/09 ruby-debug-ide 0.4.7 1.3.5 3.4.5r3 XP OK See http://wiki.github.com/mark-moseley/ruby-debug
8/8/09 ruby-debug19 0.11.5 1.3.5 3.4.5r3 XP OK See http://wiki.github.com/mark-moseley/ruby-debug
8/11/09 pg (postgres) 0.8.0 1.3.5 3.4.5r3 WinXP Pro OK requires the headers
10/18/09 rjb ? 1.3.5 3.4.5r3 XP Broken You can get it to work by adding a —export-all to the flags
10/08/09 ferret 0.11.6 1.3.5 3.4.5r3 XP Broken known to not be 1.9 compat at all
11/3/09 amalgalite 0.12.0 1.3.5 NA WinXP Pro OK x86-mingw32 binary gem
10/23/09 hitimes 1.0.4 1.3.5 NA WinXP Pro OK
10/23/09 event_hook 1.0.1 1.3.5 NA WinXP Pro Broken known to not be compatible yet with 1.9 at all
09/02/09 RMagick 2.11.0 1.3.5 3.4.5r3 XP Broken OK with some TLC
02/09/09 oniguruma 1.1.0 1.3.5 3.4.5r3 XP Broken
12/12/09 sys-proctable 0.9.0 1.3.5 NA XP OK gem install sys-proctable --platform=mswin32
9/23/09 RubyInline 1.3.5 3.4.5r3 WinXP Pro Broken this fork might work
11/11/09 fxruby 1.6.20 1.3.5 NA XP OK
11/12/09 ruby-wmi 0.2.2 1.3.5 NA XP Broken require small patch or use rdp-ruby-wmi
12/12/09 perftools.rb 0.4.0 1.3.5 NA XP Broken google perf tools’ cpu profiler isn’t ported to doze yet
12/30/09 mongo_ext 0.18.2 1.3.5 3.4.5r3 Vista Home Premium OK
01/25/10 mongo_ext 0.18.3 1.3.5 3.4.5r3 Vista Home Premium OK
01/14/10 wxruby 2.0.1 1.3.5 NA XP OK gem install --no-rdoc --no-ri wxruby-ruby19
01/25/10 serialport 1.0.1 1.3.5 3.4.5r3 XP, 7 OK
01/25/10 ruby-serialport 0.7.0 1.3.5 3.4.5r3 XP, 7 Broken use serialport gem instead
02/18/10 ruby-odbc 0.9999 1.3.5 3.4.5r3 XP OK
02/25/10 showoff 0.1.0 1.3.5 3.4.5r3 XP OK
03/24/10 win32-api 1.4.6 1.3.6 3.4.5r3 WP Broken to install it and have it not be broken, install devkit, do gem install win32-api --platform=ruby
6/13/11 tk XP OK see here for a list of options available to you for installing it on 1.9 or 1.8
07/06/10 curb 0.7.7.1 1.3.7 3.4.5r3 XP, Win7 x86 OK Installs with DevKit and libcurl installed. Also work on 1.9.2(Direct link with libcurl.dll, not libcurl.a)
*Legend* **NA** = Not Applicable. No compiler needed. For example, some native Gems are built in such a way as to not need the DevKit


 RubyInstaller 1.8.7p249

Date Gem Version RubyGems DevKit* OS Status Notes
02/07/10 redcloth 4.2.2 1.3.5 3.4.5r3 7 OK
02/16/10 hpricot 0.8.2 1.3.5 3.4.5r3 XP OK

Legend
NA = Not Applicable. No compiler needed. For example, some native Gems are built in such a way as to not need the DevKit


 RubyInstaller 1.8.6p383

Date Gem Version RubyGems DevKit* OS Status Notes
10/18/09 buildr 1.3.4 1.3.5 NA XP OK gem install --platform=mswin32
0/2/09 oniguruma 1.1.0 1.3.5 NA XP OK gem install --platform=mswin32
10/08/09 ferret 0.11.6 1.3.5 3.4.5r3 XP OK
10/23/09 amalgalite 0.11.0 1.3.5 NA WinXP Pro OK
10/23/09 hitimes 1.0.4 1.3.5 NA WinXP Pro OK x86-mingw binaries available
10/23/09 event_hook 1.0.1 1.3.5 3.4.5r3 WinXP Pro OK needs compiler at runtime
10/23/09 open4 1.0.1 1.3.5 NA WinXP Pro fail proper install instructions not known (if they exist)
01/18/10 ruby-opengl 0.60.1 1.3.5 NA XP Broken Cannot get to install even with —platform option. Can download the gem manually from rubyforge and it will install, but then programs fail with a cannot find glut32.dll error.
9/23/09 RubyInline 1.3.5 3.4.5r3 WinXP Pro OK
01/03/10 ParseTree 1.3.6 3.0.3 Win7 OK version > 3.0.3 fail
11/11/09 eventmachine 0.12.10 1.3.5 3.4.5r3 XP OK
11/11/09 json 1.1.0 1.3.5 3.4.5r3 XP OK gem install --platform=mswin32
11/11/09 fxruby 1.6.20 1.3.5 NA XP OK
02/12/09 ruby-oci8 1.0.7 1.3.5 NA XP OK gem install --platform=mswin32
12/12/09 sys-proctable 0.9.0 1.3.5 NA XP OK gem install sys-proctable --platform=mswin32
01/29/10 serialport 1.0.1 1.3.5 3.4.5r3 XP, 7 OK
01/14/10 wxruby 2.0.1 1.3.5 NA XP OK
01/25/10 typhoeus any 1.3.5 3.4.5r3 XP Vista Broken could not find curl/curl.h. need libcurl
01/29/10 pg (postgres) 0.8.0 1.3.5 3.4.5r3 7 OK gem install --platform=mswin32
01/29/10 libxml-ruby 1.1.3 1.3.5 3.4.5r3 7 OK gem install --platform=mswin32
01/25/10 ruby-serialport 0.7.0 1.3.5 3.4.5r3 XP, 7 Broken use serialport gem instead
02/18/10 ruby-odbc 0.9999 1.3.5 3.4.5r3 XP OK
02/18/10 odbc 0.9999 1.3.5 3.4.5r3 XP OK

Legend
NA = Not Applicable. No compiler needed. For example, some native Gems are built in such a way as to not need the DevKit

Something went wrong with that request. Please try again.