Skip to content
Fetching contributors…
Cannot retrieve contributors at this time
94 lines (89 sloc) 3.18 KB
# Generated by jeweler
# DO NOT EDIT THIS FILE
# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{ruby-hl7}
s.version = "1.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Mark Guzman", 'One Medical Group']
s.date = %q{2011-01-25}
s.description = %q{A simple library to parse and generate HL7 2.x messages}
s.email = %q{ruby-hl7@googlegroups.com}
s.extra_rdoc_files = [
"LICENSE",
"README.rdoc"
]
s.files = [
"lib/ruby-hl7.rb",
"lib/segments/err.rb",
"lib/segments/evn.rb",
"lib/segments/msa.rb",
"lib/segments/msh.rb",
"lib/segments/nk1.rb",
"lib/segments/nte.rb",
"lib/segments/obr.rb",
"lib/segments/obx.rb",
"lib/segments/orc.rb",
"lib/segments/oru.rb",
"lib/segments/pid.rb",
"lib/segments/pv1.rb",
"lib/segments/pv2.rb",
"lib/segments/qrd.rb",
"lib/segments/qrf.rb",
"lib/segments/sft.rb",
"lib/segments/spm.rb",
"lib/string.rb",
"lib/test/hl7_messages.rb",
"test_data/adt_a01.hl7",
"test_data/cerner/cerner_bordetella.hl7",
"test_data/cerner/cerner_en.hl7",
"test_data/cerner/cerner_lead.hl7",
"test_data/cerner/cerner_sequential.hl7",
"test_data/empty-batch.hl7",
"test_data/empty.hl7",
"test_data/empty_segments.hl7",
"test_data/lotsunknowns.hl7",
"test_data/nist/ORU_R01_2.5.1_SampleTestCase1.er7",
"test_data/nist/ORU_R01_2.5.1_SampleTestCase2.er7",
"test_data/nist/ORU_R01_2.5.1_SampleTestCase3.er7",
"test_data/nist/ORU_R01_2.5.1_SampleTestCase4.er7",
"test_data/nist/ORU_R01_2.5.1_SampleTestCase5.er7",
"test_data/nist/ORU_R01_2.5.1_SampleTestCase6.er7",
"test_data/obxobr.hl7",
"test_data/realm/realm-animal-rabies.hl7",
"test_data/realm/realm-bad-batch.hl7",
"test_data/realm/realm-batch.hl7",
"test_data/realm/realm-campylobacter-jejuni.hl7",
"test_data/realm/realm-cj-badloinc.hl7",
"test_data/realm/realm-cj-joeslab.hl7",
"test_data/realm/realm-cj.hl7",
"test_data/realm/realm-err.hl7",
"test_data/realm/realm-hepatitis-c-virus.hl7",
"test_data/realm/realm-lead-laboratory-result.hl7",
"test_data/realm/realm-minimal-message.hl7",
"test_data/rqi_r04.hl7",
"test_data/test.hl7",
"test_data/test2.hl7"
]
s.homepage = %q{http://github.com/onemedical/ruby-hl7}
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
s.required_ruby_version = Gem::Requirement.new(">= 1.8.6")
s.rubyforge_project = %q{ruby-hl7}
s.rubygems_version = %q{1.4.2}
s.summary = %q{Ruby HL7 Library fork}
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.3.0') then
s.add_runtime_dependency(%q<rake>, [">= 0.8.7"])
s.add_runtime_dependency(%q<rubyforge>, [">= 2.0.4"])
else
s.add_dependency(%q<rake>, [">= 0.8.7"])
s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
end
else
s.add_dependency(%q<rake>, [">= 0.8.7"])
s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
end
end
Something went wrong with that request. Please try again.