Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Report ID field is empty in the raw data section #188

Closed
hellais opened this Issue Jan 30, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@hellais
Copy link
Member

hellais commented Jan 30, 2019

Expected Behavior

When I go into the view data section of the app I should see in the report_id populated with a value.

This does not happen on probe-ios.

Actual Behavior

The report_id field contains the empty strings "".

See:
signal-attachment-2019-01-31-104928

Steps to Reproduce the Problem

  1. Run any experiment on android
  2. Go the view data section of the measurement via the option menu
  3. Notice how the report_id field is empty

Specifications

  • Version: 2.0.0
  • Platform: android

@hellais hellais added the bug label Jan 30, 2019

@hellais hellais added this to the OONI Probe 2.1 milestone Jan 30, 2019

@hellais

This comment has been minimized.

Copy link
Member Author

hellais commented Jan 31, 2019

It could be that the root cause of this problem is that the measurement was not created properly.

This issue appears to be very pervasive on probe-android as we have seen significantly fewer measurements than expected.

Since 2019-01-01 we have recorded:
45718 measurements coming from ooniprobe-android 2.0.0
79414 measurements coming from ooniprobe-ios 2.0.0

Yet the iOS userbase is ~10x smaller than android, so I would have expected to see at least as many if not much more measurements coming from android, which is not the case.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.