New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to update the certificate. #75

Closed
apisit opened this Issue Nov 3, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@apisit

apisit commented Nov 3, 2017

Hi,
I am using ID-card utility version. 3.12.9.1261 and I have been trying to update the e-residency certificate but unable to do so.

Here is the response I received.

screen shot 2017-11-03 at 8 09 49 pm

This is the info when I click Details button.

Connecting to "https://id-gw.eesti.ee/update/"
Proxy "" : 0 User ""
< {"cmd":"START","lang":"en","platform":"Mac OS 10.12.6 (64/x86_64)","version":"3.12.9.1261"}

Not really sure whether the server is really overloaded or just my machine.
However, I just want to report it.

@djordjevanjek

This comment has been minimized.

Show comment
Hide comment
@djordjevanjek

djordjevanjek Nov 3, 2017

Had the same issue but after trying a dozen of times managed to get to the next screen:

23261874_10215109079748289_891289848_o

My initial thought was that it passed and that it should work now, but oh well...
Updating failed again, now with the red text and following details:

{"cmd":"DIALOG","text":"For updating certificates please close all programs which are interacting with smartcard (DigiDoc Client, DigiDoc Crypto, Chrome, Firefox, Safari, Internet Explorer...)<a href=\"http:\/\/www.id.ee\/?id=37548\">More info<\/a>.<br \/><br \/>After updating certificates it will no longer be possible to decrypt documents that were encrypted with the old certificate!<br \/><br \/>If the renewal of the certificates has failed, you can try again within 30 days. After that, you can only renew your ID-card certificates at any service center of the Police and Border Guard Board.<br \/><br \/><a href=\"https:\/\/www.politsei.ee\/dotAsset\/674066.pdf\">Conditions for Use of Certificates<\/a>.","session":"..."}

If I try to do it again, I am back to:

Connecting to "https://id-gw.eesti.ee/update/" Proxy "" : 0 User "" < {"cmd":"START","lang":"en","platform":"Mac OS 10.13.1 (64/x86_64)","version":"3.12.9.1261"}

After trying a few more times, managed to pass the first step again, but now my ID-card certificate renewal has been suspended.

screen shot 2017-11-03 at 6 49 40 pm

Slowly losing my patience (:

djordjevanjek commented Nov 3, 2017

Had the same issue but after trying a dozen of times managed to get to the next screen:

23261874_10215109079748289_891289848_o

My initial thought was that it passed and that it should work now, but oh well...
Updating failed again, now with the red text and following details:

{"cmd":"DIALOG","text":"For updating certificates please close all programs which are interacting with smartcard (DigiDoc Client, DigiDoc Crypto, Chrome, Firefox, Safari, Internet Explorer...)<a href=\"http:\/\/www.id.ee\/?id=37548\">More info<\/a>.<br \/><br \/>After updating certificates it will no longer be possible to decrypt documents that were encrypted with the old certificate!<br \/><br \/>If the renewal of the certificates has failed, you can try again within 30 days. After that, you can only renew your ID-card certificates at any service center of the Police and Border Guard Board.<br \/><br \/><a href=\"https:\/\/www.politsei.ee\/dotAsset\/674066.pdf\">Conditions for Use of Certificates<\/a>.","session":"..."}

If I try to do it again, I am back to:

Connecting to "https://id-gw.eesti.ee/update/" Proxy "" : 0 User "" < {"cmd":"START","lang":"en","platform":"Mac OS 10.13.1 (64/x86_64)","version":"3.12.9.1261"}

After trying a few more times, managed to pass the first step again, but now my ID-card certificate renewal has been suspended.

screen shot 2017-11-03 at 6 49 40 pm

Slowly losing my patience (:

@tynisr

This comment has been minimized.

Show comment
Hide comment
@tynisr

tynisr Nov 4, 2017

Hi

As of midnight Estonian local time all the vulnerable certificates have been suspended (meaning they can not be used until renewed). At the moment the online certificate renewal is available only for critical personel (like medical workers, rescue and security) and heavy everyday users (for example people using it daily for login).
We expect the online certificate renewal to be available again for the general public on Monday, but server overload can still be expected. Unless you need to use your electronic ID immediately next week you should not rush the update, the update will remain available until 31.03.2018.
For further information please contact the e-recidency program. See also: http://id.ee/index.php?id=30610&read=38344

For support please contact with:

Help centre : http://id.ee/index.php?id=30466
Helpline (+372) 677 3377 with English support
E-mail abi@id.ee

tynisr commented Nov 4, 2017

Hi

As of midnight Estonian local time all the vulnerable certificates have been suspended (meaning they can not be used until renewed). At the moment the online certificate renewal is available only for critical personel (like medical workers, rescue and security) and heavy everyday users (for example people using it daily for login).
We expect the online certificate renewal to be available again for the general public on Monday, but server overload can still be expected. Unless you need to use your electronic ID immediately next week you should not rush the update, the update will remain available until 31.03.2018.
For further information please contact the e-recidency program. See also: http://id.ee/index.php?id=30610&read=38344

For support please contact with:

Help centre : http://id.ee/index.php?id=30466
Helpline (+372) 677 3377 with English support
E-mail abi@id.ee

@tynisr tynisr closed this Nov 4, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment