Skip to content

Add repo on fresh installation produces Application Error #222

Closed
dl9pf opened this Issue Mar 18, 2013 · 3 comments

3 participants

@dl9pf
dl9pf commented Mar 18, 2013

Env:
Fresh setup - no repositories defined.

http://my.obs/project/add_repository_from_default_list?project=foo_bar

Fails with:

Application error

500

Should bail out with message "No repos available to be added" or similar in error box instead of app error.

@dl9pf
dl9pf commented Mar 18, 2013

==> api/log/production.log <==
[INFO |#28000] Started GET "/distributions/include_remotes" for 8x.19y.3x.1y at 2013-03-18 20:33:36 +0200
[INFO |#28000] Processing by DistributionsController#include_remotes as XML
[INFO |#28000] Completed 500 Internal Server Error in 426ms

[FATAL|#28000] OpenSSL::SSL::SSLError (SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed):
lib/activexml/transport.rb:418:in load_external_url'
app/models/distribution.rb:43:in
block (2 levels) in all_including_remotes'
app/models/distribution.rb:42:in block in all_including_remotes'
app/models/distribution.rb:41:in
all_including_remotes'
app/controllers/distributions_controller.rb:24:in include_remotes'
config/initializers/wrap_parameters.rb:35:in
call'

==> api/log/apache_access_log <==
8x.19y.3x.1 - - [18/Mar/2013:20:33:36 +0200] "GET /distributions/include_remotes HTTP/1.1" 500 -

==> webui/log/production.log <==
[INFO |#28042] Completed 500 Internal Server Error in 590ms

[FATAL|#28042] ActiveXML::Transport::Error (#Net::HTTPInternalServerError:0x000000068a6de8):
lib/activexml/transport.rb:461:in handle_response'
lib/activexml/transport.rb:400:in
http_do'
lib/activexml/transport.rb:172:in find'
lib/activexml/node.rb:146:in
block in find_priv'
lib/activexml/node.rb:144:in find_priv'
lib/activexml/node.rb:178:in
find_cached'
app/controllers/application_controller.rb:200:in find_cached'
app/controllers/project_controller.rb:295:in
add_repository_from_default_list'

@KostyaSha

server certificate B: certificate verify failed
fix you ssl certs or hack lib/activexml/transport.rb to allow all ssl's
duplicate for #207

@hennevogel
The openSUSE Project member

should be fixed in 2.4. please re-test. thanks

@hennevogel hennevogel closed this Jan 10, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.