Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

v2 cgroup delegation fails: memory.oom.group: no such file or directory #3387

Closed
dkadioglu opened this issue Feb 21, 2022 · 2 comments · Fixed by #3389
Closed

v2 cgroup delegation fails: memory.oom.group: no such file or directory #3387

dkadioglu opened this issue Feb 21, 2022 · 2 comments · Fixed by #3389

Comments

@dkadioglu
Copy link

dkadioglu commented Feb 21, 2022

After the update of runc from 1.0.3 to 1.1.0, one of my containers doesn't start anymore and errors out with the following message:
Error response from daemon: Cannot restart container dkhm: failed to create shim: OCI runtime create failed: runc create failed: unable to start container process: unable to apply cgroup configuration: chown /sys/fs/cgroup/system.slice/docker-77a1ac22d8bfb1658e9bb8430d7dd8c75e8fad69b4e3b389f8d25a09fde26d21.scope/memory.oom.group: no such file or directory: unknown Downgrading to 1.0.3 fixes it and the container starts again.

My 16 other containers run as before.

My host:

  • RPi 4B 8G
  • Arch Linux ARM fully updated

I have no clue where to start searching for the culprit of all this. Is there any further info, which might help to investigate this?

@kolyshkin kolyshkin changed the title Container runs with 1.0.3 but not with 1.1.0 v2 cgroup delegation fails: memory.oom.group: no such file or directory Feb 21, 2022
@kolyshkin
Copy link
Contributor

kolyshkin commented Feb 21, 2022

Thanks for reporting this!

Looks like a regression from #3057. The workaround for you would be to NOT mount /sys/fs/cgroup read-write.

The proposed fix is #3389. You can test it by using a pre-built binary for your arch (arm64 I guess) from the zip archive at the very bottom of this page: https://github.com/opencontainers/runc/actions/runs/1877860537

@dkadioglu
Copy link
Author

dkadioglu commented Feb 21, 2022

Thank you very much for looking into this! And for providing a fix so fast!
I rebuilt runc 1.1.0 including the mentioned patch and so far it seems to work again, i.e. the respective container starts and runs now. Perfect!
Just to mention: I am still on armv7h.

frasertweedale added a commit to frasertweedale/runtime-spec that referenced this issue Feb 22, 2022
Not all files listed in /sys/kernel/cgroup/delegate necessarily
exist in all cgroups.  For example, see this issue and PR:

- opencontainers/runc#3387
- opencontainers/runc#3389

Expand the cgroup ownership semantics to ensure that runtime authors
are aware of this possibility and implementations handle it
gracefully.

Signed-off-by: Fraser Tweedale <ftweedal@redhat.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging a pull request may close this issue.

2 participants