Permalink
Browse files

ci-tools: versions of golang

Add and update golang versions. Also fix install.tools target for
installing govet

Signed-off-by: Vincent Batts <vbatts@hashbangbash.com>
  • Loading branch information...
1 parent ad9d643 commit d4ede0d364554eb8939415237f82cb2c6c6f4f3f @vbatts vbatts committed Aug 29, 2016
Showing with 6 additions and 13 deletions.
  1. +3 −2 .travis.yml
  2. +3 −11 Makefile
View
@@ -1,7 +1,8 @@
language: go
go:
- - 1.6
- - 1.5.3
+ - 1.7
+ - 1.6.3
+ - 1.5.4
sudo: required
View
@@ -68,9 +68,7 @@ ALLOWED_GO_VERSION = $(shell test '$(shell /bin/echo -e "$(1)\n$(2)" | sort -V |
test: .govet .golint .gitvalidation
-# `go get golang.org/x/tools/cmd/vet`
.govet:
- @go tool | grep -qw vet || (echo "ERROR: 'go vet' not found. Consider 'make install.tools' target" && false)
go vet -x ./...
# `go get github.com/golang/lint/golint`
@@ -92,22 +90,16 @@ endif
.PHONY: install.tools
-install.tools: .install.golint .install.govet .install.gitvalidation
+install.tools: .install.golint .install.gitvalidation
# golint does not even build for <go1.5
.install.golint:
ifeq ($(call ALLOWED_GO_VERSION,1.5,$(HOST_GOLANG_VERSION)),true)
- go get github.com/golang/lint/golint
-endif
-
-# go vet is now included in >=go1.5, so no need to get it.
-.install.govet:
-ifeq ($(call ALLOWED_GO_VERSION,1.5,$(HOST_GOLANG_VERSION)),true)
- go get golang.org/x/tools/cmd/vet
+ go get -u github.com/golang/lint/golint
endif
.install.gitvalidation:
- go get github.com/vbatts/git-validation
+ go get -u github.com/vbatts/git-validation
.PHONY: clean

0 comments on commit d4ede0d

Please sign in to comment.