New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

feat(install): update scripts to upgrade to 0.8.0 #2314

Merged
merged 1 commit into from Dec 7, 2018

Conversation

Projects
None yet
2 participants
@kmova
Copy link
Member

kmova commented Dec 4, 2018

Make changes to samples and upgrade scripts to make use of 0.8.0 features.

  • Add a section to upgrade to 0.8.0
  • Add new sample YAMLs for cStor snapshot and clone
  • Update sample chart yamls to 0.8.0

@kmova kmova force-pushed the kmova:upgrade-0.8.0 branch from d3453d7 to 21358eb Dec 6, 2018

@kmova kmova requested review from prateekpandey14 and AmitKumarDas Dec 6, 2018

@kmova kmova force-pushed the kmova:upgrade-0.8.0 branch from 4fe058c to edbb1f4 Dec 6, 2018

@kmova kmova changed the title [WIP] feat(install): update scripts to upgrade to 0.8.0 feat(install): update scripts to upgrade to 0.8.0 Dec 6, 2018

Show resolved Hide resolved k8s/charts/openebs/README.md Outdated
- name: OPENEBS_IO_ENABLE_ANALYTICS
value: "{{ .Values.analytics.enabled }}"
# OPENEBS_IO_ANALYTICS_PING_INTERVAL can be used to specify the duration (in hours)
# for periodic ping events sent to Google Analytics. Default is 24 hours.

This comment has been minimized.

@AmitKumarDas

AmitKumarDas Dec 7, 2018

Member

Can we put some valid values as samples?

This comment has been minimized.

@kmova

kmova Dec 7, 2018

Member

Updated the comments. Please check.

@kmova kmova force-pushed the kmova:upgrade-0.8.0 branch from edbb1f4 to 735616e Dec 7, 2018

feat(install): upgrade scripts, yamls for 0.8.0
- Created upgrade scripts for 0.7.x to 0.8.0
  - Create patch files for jiva, cstor volumes
  - Create patch files for cStor pools
  - Update instructions
- Update the openebs-operator.yaml with new ENV
  for analytics
- Remove the unused maya-apiserver install configmap
- Update the charts with 0.8.0 changes
- Also includes some minor updates to the demo YAML files

Signed-off-by: kmova <kiran.mova@openebs.io>

@kmova kmova force-pushed the kmova:upgrade-0.8.0 branch from 735616e to 483a37e Dec 7, 2018

@kmova kmova merged commit 95ac0c6 into openebs:master Dec 7, 2018

2 checks passed

Better Code Hub ✅ Better Code Hub approves this code
Details
DCO All commits are signed off!
Details

@kmova kmova deleted the kmova:upgrade-0.8.0 branch Dec 7, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment