patient notes - empty value on user select box #366

Closed
avi-matrix opened this Issue Nov 29, 2016 · 9 comments

Projects

None yet

2 participants

@avi-matrix
Contributor

when trying to add a new note for a patient, the first option of the users selection is hard-coded and not containing any value, which leaves the addressee empty.
Is the first choice with the empty value is required to the functionality? Or I can feel safe to delete it and enforce select a recipient?
Thanks.

@bradymiller bradymiller self-assigned this Dec 1, 2016
@bradymiller
Member

Hi,

@bradymiller
Member

oops on the above note, hit enter before placing my message :)

I am not able to confirm this. Can you show a quick screenshot?
thanks, -brady

@avi-matrix
Contributor

hey, sorry for the late response.
go to Patient file -> notes -> new note
you will see that the first selection is "** closed **" with no value at all..
it is hardcoded.
image

@bradymiller
Member

That is odd, the most recent development demo does not have this issue:
http://www.open-emr.org/wiki/index.php/Development_Demo#Daily_Build_Development_Demo

In the demo it selects 'Administrator' user by default.

@avi-matrix
Contributor

the Administrator user is really selected by default, but did you tried to open it and take a look at the options? this should be the first option.
for now it looks like this is unnecessary and can be removed.

@bradymiller
Member

I see what you are saying. I agree that it makes sense to enforce an addressee(ie. remove the empty value).

@bradymiller
Member

@avi-matrix ,
Just checking if I missed the fix for this?
thanks,
-brady

@avi-matrix
Contributor

brady, please check this pull request
#429

@bradymiller
Member

Looks good. Will bring the fix into the codebase. thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment