Permalink
Browse files

archlinux install_dependencies: don't try to recompile poco anymore

  • Loading branch information...
arturoc committed Jul 13, 2017
1 parent 36daa56 commit 1ca9f8bd0a427ad64eee0b846c5dde636056c9fa
Showing with 0 additions and 20 deletions.
  1. +0 −20 scripts/linux/archlinux/install_dependencies.sh
@@ -26,23 +26,3 @@ echo "OpenFramworks requires rtaudio. This package is not in the official reposi
echo ""
read -p "Press any key to continue... " -n1 -s
export LC_ALL=C
GCC_MAJOR_GT_4=$(expr `gcc -dumpversion | cut -f1 -d.` \> 4)
if [ $GCC_MAJOR_GT_4 -eq 1 ]; then
echo
echo
echo "It seems you are running gcc 5 or later, due to incomatible ABI with previous versions"
echo "we need to recompile poco. This will take a while"
read -p "Press any key to continue... " -n1 -s
sys_cores=$(getconf _NPROCESSORS_ONLN)
if [ $sys_cores -gt 1 ]; then
cores=$(($sys_cores-1))
else
cores=1
fi
DIR=$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )
cd ${DIR}/../../apothecary/apothecary
./apothecary -j${cores} update poco
fi

0 comments on commit 1ca9f8b

Please sign in to comment.