Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

WIndows 8 videoGrabber pixelates and crops image #1962

Open
danzeeeman opened this Issue Mar 21, 2013 · 1 comment

Comments

Projects
None yet
2 participants
Member

danzeeeman commented Mar 21, 2013

I'm seeing some very strange issues with Windows 8 and the ofDirectShowGrabber. The videoGrabber isn't working correctly. I've uploaded 4 images here that illustrate the issues I'm seeing and the differences between oF Win, oF OS X, and p5 Win. I captured these images using the videoGrabber example. I made simple changes to set the grabber's size to 1920x1080 and added something to save the frame. I'm using the Microsoft LifeCam Studio as my camera but can reproduce the issue with other high res webcams. It looks like the requested size is failing and it is falling back to some default value then scaling the image up to the requested size. When I run the same oF project on OS X and a similar p5 sketch on Windows using the same webcam it works perfectly.

So I dug deeper and tested the videoInput library and saw some of the same issues but just the requested size failing and not the scaling up to the requested size when draw. I also tested Cinder and it is a problem there too. Looks like they are also using something based off of @ofTheo's old videoInput library as well. Any ideas?

Contributor

ofZach commented Mar 21, 2015

is this still an issue? (I've noticed the other related issue #1364 is closed). I think the default on OSX had always been to try to open to the requested size and to resize internally (AFAIK, it was actually not even in OF where the resize was happening on the OSX side).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment