Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ofSetBackgroundAuto=false not working on Raspberry Pi #5021

Open
critterandguitari opened this issue Mar 28, 2016 · 5 comments
Open

ofSetBackgroundAuto=false not working on Raspberry Pi #5021

critterandguitari opened this issue Mar 28, 2016 · 5 comments

Comments

@critterandguitari
Copy link

@critterandguitari critterandguitari commented Mar 28, 2016

Calling ofSetBackgroundAuto(false); in setup() has no effect on Raspberry Pi 2 (BG is still cleared every time)

Running on Raspberry Pi 2 with of_v0.9.3_linuxarmv6l_release

Following code works as expected on a Mac, but not on Raspberry Pi

void ofApp::setup(){
    ofSetBackgroundAuto(false);
    ofSetFrameRate(30);
}

void ofApp::draw(){
    ofFill();
    for (int i = 0; i < 10; i++){
        ofSetColor((int)ofRandom(0,255),(int)ofRandom(0,255),(int)ofRandom(0,255));
        ofDrawRectangle(ofRandom(0,1280),ofRandom(0,720),ofRandom(10,200),ofRandom(10,200));
    }
}
@krisrok

This comment has been minimized.

Copy link
Contributor

@krisrok krisrok commented Oct 20, 2017

it's driving me crazy i only now stumbled upon this issue

@mcanet

This comment has been minimized.

Copy link
Contributor

@mcanet mcanet commented Nov 5, 2017

It is also happening with Raspberry pi 3 with of_v0.9.8_linuxarmv6l_release in Raspbian Jessie(BG is still cleared every time).

@rvegele

This comment has been minimized.

Copy link
Contributor

@rvegele rvegele commented Oct 9, 2018

same issue

@DiglDixon

This comment has been minimized.

Copy link

@DiglDixon DiglDixon commented Oct 29, 2018

Would love a fix for this when possible :)

@wednesdayayay

This comment has been minimized.

Copy link

@wednesdayayay wednesdayayay commented Feb 7, 2020

I would also love to see a fix to this but for now I suppose I'll redo things and add FBO in

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
6 participants
You can’t perform that action at this time.