Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Could not find artifact vigna.dsi.unimi.it:jal:jar:20031117 in openimaj (http://maven.openimaj.org/) #167

Closed
ng1905 opened this issue Jul 3, 2019 · 4 comments

Comments

Projects
None yet
2 participants
@ng1905
Copy link

commented Jul 3, 2019

Tested with org.openimaj faces v1.3.8 and v1.3.7

Artifact vigna.dsi.unimi.it does no longer exist in maven central nor openimaj's own repository, making a maven build with openimaj impossible.

I came across this issue a few days ago. Without changing anything, my build process started to fail. After running mvn dependency:tree --debug, I saw that the missing artifact belongs to openimaj.

Full output:

[ERROR] Failed to execute goal on project oms-server: Could not resolve dependencies for project de.ngsger:oms-server:jar:0.16-SNAPSHOT: The following artifacts could not be resolved: vigna.dsi.unimi.it:jal:jar:20031117, net.sf.jafama:JaFaMa:jar:1.2, jgrapht:jgrapht:jar:0.8.2: Could not find artifact vigna.dsi.unimi.it:jal:jar:20031117 in openimaj (http://maven.openimaj.org/)
@jonhare

This comment has been minimized.

Copy link
Member

commented Jul 4, 2019

Ok, I think I've fixed this now. Please let me know if it works for you, or if you run into further missing dependencies.

@ng1905

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

First of all, thank you very much for the quick reply.

As far as I can tell, the dependencies issue is resolved except for net.sf.jafama:JaFaMa:jar:1.2, which still causes any builds to fail.

@jonhare

This comment has been minimized.

Copy link
Member

commented Jul 10, 2019

Ok, sorry for the delay - that should be fixed too: http://maven.openimaj.org/net/sf/jafama/JaFaMa/1.2/JaFaMa-1.2.jar

@ng1905

This comment has been minimized.

Copy link
Author

commented Jul 12, 2019

No problem at all. It seems like Github doesn't want to send me mail notifications either way, so I just saw your comment and tried it. Works like a charm, thanks for fixing this and maintaining the project :)

@ng1905 ng1905 closed this Jul 12, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.