Skip to content
Permalink
Browse files

8226754: FX build fails using gradle 5.6+ or 6

Remove obsolete STABLE_PUBLISHING; explicitly set output.resourcesDir; bump minimum gradle version to 5.3

Reviewed-by: jvos
  • Loading branch information...
kevinrushforth committed Oct 14, 2019
1 parent 63fe66c commit 64aaeb840aa157e358eb41001c3705aa5c2fee30
Showing with 3 additions and 5 deletions.
  1. +2 −0 build.gradle
  2. +1 −1 build.properties
  3. +0 −4 settings.gradle
@@ -3810,6 +3810,7 @@ allprojects {
project.jar.enabled = false

// and redirect the resources into the module
project.sourceSets.main.output.resourcesDir = project.moduleDir
project.processResources.destinationDir = project.moduleDir
}

@@ -3843,6 +3844,7 @@ allprojects {
project.sourceSets.shims.resources.srcDirs += project.sourceSets.main.resources.srcDirs

// and redirect the resources into the module
project.sourceSets.shims.output.resourcesDir = project.moduleShimsDir
project.processShimsResources.destinationDir = project.moduleShimsDir

compileTestJava.dependsOn(copyGeneratedShimsTask)
@@ -85,7 +85,7 @@ jfx.build.jdk.buildnum.min=28
# The jfx.gradle.version.min property defines the minimum version of gradle
# that is supported. It must be <= jfx.gradle.version.
jfx.gradle.version=5.3
jfx.gradle.version.min=4.8
jfx.gradle.version.min=5.3

# Toolchains
jfx.build.linux.gcc.version=gcc8.2.0-OL6.4+1.0
@@ -35,10 +35,6 @@ project(":web").projectDir = file("modules/javafx.web")
project(":media").projectDir = file("modules/javafx.media")
project(":systemTests").projectDir = file("tests/system")

// Stable publishing behavior is the default in gradle 5.x.
// This setting enables it in gradle 4.8 to help with the transition.
enableFeaturePreview('STABLE_PUBLISHING')

def closedDir = file("../rt-closed")
def buildClosed = closedDir.isDirectory()

0 comments on commit 64aaeb8

Please sign in to comment.
You can’t perform that action at this time.