Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files
8241232: -XX:+BootstrapJVMCI is not compatible with TieredStopAtLevel…
… < CompLevel_full_optimization

Reviewed-by: kvn, thartmann
  • Loading branch information
DamonFool committed Mar 19, 2020
1 parent cadfc3d commit dd63eec6e590fa8b77346db2731e43fb5a897a0e
Showing with 48 additions and 0 deletions.
  1. +5 −0 src/hotspot/share/jvmci/jvmci_globals.cpp
  2. +43 −0 test/hotspot/jtreg/compiler/jvmci/errors/TestInvalidTieredStopAtLevel.java
@@ -92,6 +92,11 @@ bool JVMCIGlobals::check_jvmci_flags_are_consistent() {
jio_fprintf(defaultStream::error_stream(), "-XX:+BootstrapJVMCI is not compatible with -XX:+UseJVMCINativeLibrary\n");
return false;
}
if (BootstrapJVMCI && (TieredStopAtLevel < CompLevel_full_optimization)) {
jio_fprintf(defaultStream::error_stream(),
"-XX:+BootstrapJVMCI is not compatible with -XX:TieredStopAtLevel=%d\n", TieredStopAtLevel);
return false;
}
}

if (!EnableJVMCI) {
@@ -0,0 +1,43 @@
/*
* Copyright (C) 2020 THL A29 Limited, a Tencent company. All rights reserved.
* DO NOT ALTER OR REMOVE NOTICES OR THIS FILE HEADER.
*
* This code is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License version 2 as
* published by the Free Software Foundation. THL A29 Limited designates
* this particular file as subject to the "Classpath" exception as provided
* by Oracle in the LICENSE file that accompanied this code.
*
* This code is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License version 2 for more details.
*
* You should have received a copy of the GNU General Public License along
* with this program; if not, write to the Free Software Foundation, Inc.,
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
*/

/**
* @test
* @bug 8241232
* @requires vm.jvmci
* @library /test/lib
* @build TestInvalidTieredStopAtLevel jdk.test.lib.process.*
* @run main TestInvalidTieredStopAtLevel
*/

import jdk.test.lib.process.ProcessTools;

public class TestInvalidTieredStopAtLevel {
public static void main(String... args) throws Exception {
ProcessTools.executeTestJava("-XX:+UnlockExperimentalVMOptions",
"-XX:+UseJVMCICompiler",
"-XX:+BootstrapJVMCI",
"-XX:TieredStopAtLevel=1",
"-Xcomp")
.outputTo(System.out)
.errorTo(System.out)
.stdoutShouldNotContain("hs_err");
}
}

0 comments on commit dd63eec

Please sign in to comment.