Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OMV 5 prevents persistent device naming #500

Closed
elfhack opened this issue Nov 8, 2019 · 1 comment
Labels

Comments

@elfhack
Copy link

@elfhack elfhack commented Nov 8, 2019

At some point the /etc/systemd/network/10-openmediavault-enp7s0.link file got included in my initrd. After that, udev would refuse to rename the interface (in my case eth2), making the network fail. It looks like the link file is missing the name.

This is not a problem when initially installing OMV5, as the initramfs doesn't get regenerated (i guess?) but it's a problem nontheless. I think it should include Name= in the [Link] section

votdev added a commit that referenced this issue Nov 9, 2019
…tings from /lib/systemd/network/99-default.link.

Signed-off-by: Volker Theile <votdev@gmx.de>
@votdev votdev added 5.x bug labels Nov 9, 2019
@votdev votdev closed this Nov 9, 2019
@votdev

This comment has been minimized.

Copy link
Collaborator

@votdev votdev commented Nov 9, 2019

Fixed in openmediavault 5.0.14.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.