Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Threshold arugment of get_histogram() doesn't adjust number of pixels sampled. #548

Closed
kwagyeman opened this issue Jul 9, 2019 · 3 comments
Closed
Labels
bug

Comments

@kwagyeman
Copy link
Member

@kwagyeman kwagyeman commented Jul 9, 2019

Issues are here:

https://github.com/openmv/openmv/blob/master/src/omv/img/stats.c#L178
https://github.com/openmv/openmv/blob/master/src/omv/img/stats.c#L217
https://github.com/openmv/openmv/blob/master/src/omv/img/stats.c#L264

Change the code to compute the number of pixels before hand and then if in threshold mode count all pixels thresholded.

@iabdalkader iabdalkader added the bug label Sep 9, 2019
@iabdalkader

This comment has been minimized.

Copy link
Member

@iabdalkader iabdalkader commented Oct 29, 2019

@kwagyeman Can you fix this soon ?

@JCP13

This comment has been minimized.

Copy link

@JCP13 JCP13 commented Dec 5, 2019

Hi,

I second that. I just made an order and I will need to use that feature when it arrives.

Thank you in advance.

@kwagyeman

This comment has been minimized.

Copy link
Member Author

@kwagyeman kwagyeman commented Dec 20, 2019

Fixed in #655

@kwagyeman kwagyeman closed this Dec 20, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.