Skip to content
Permalink
Browse files

updated release version from 0.0.2.dev7 to 0.0.2.dev8 (#32)

fix for issue#29

* pytest for setup.py
* pin qiskit version to 0.5.7

* fix pytest integration (#31)

* fixed typo in setup.py
* suppress warning of test

* updated release version from 0.0.2.dev7 to 0.0.2.dev8
  • Loading branch information...
openql-org committed Dec 28, 2018
1 parent 6713fb9 commit 18e37760a73fb4df955b44720e9a047decd744dc
Showing with 13 additions and 2 deletions.
  1. +1 −0 AUTHORS
  2. +1 −1 quantpy/release.py
  3. +1 −1 requirements.txt
  4. +7 −0 setup.cfg
  5. +2 −0 setup.py
  6. +1 −0 test-requirements.txt
@@ -2,6 +2,7 @@ All people who contributed to QuantPy by sending at least a patch or more (
in the order of the date of their first contribution), except those who
explicitly didn't want to be mentioned.

Susumu Ishizuka <susumu.ishizuka@kii.com>
Kodack <kodack64@gmail.com>
Takumi Kato <takumi.kt+github@gmail.com>
Shumpei Kobayashi <skonb@w-ax.is>
@@ -1,3 +1,3 @@
# -*- coding:utf-8 -*-

__version__ = "0.0.2.dev7"
__version__ = "0.0.2.dev8"
@@ -1,3 +1,3 @@
numpy
qiskit
qiskit == 0.5.7
sympy
@@ -0,0 +1,7 @@
# https://docs.pytest.org/en/latest/goodpractices.html#goodpractices
[aliases]
test=pytest

[tool:pytest]
filterwarnings =
ignore:the matrix subclass.*:PendingDeprecationWarning
@@ -54,4 +54,6 @@ def _test_requirements():
],
python_requires=">=3.5",
install_requires=_requirements(),
tests_require=_test_requirements(),
setup_requires=['pytest-runner']
)
@@ -0,0 +1 @@
pytest

0 comments on commit 18e3776

Please sign in to comment.
You can’t perform that action at this time.