Permalink
Browse files

updated docs to reflect recent changes.

  • Loading branch information...
1 parent 5f9684b commit 27bcbd290ff729afff9bd40545e85598f390c147 @agentzh agentzh committed Nov 20, 2012
Showing with 69 additions and 36 deletions.
  1. +23 −15 README
  2. +25 −11 README.markdown
  3. +21 −10 doc/HttpHeadersMoreModule.wiki
View
38 README
@@ -6,9 +6,9 @@ Name
installation instructions.
Version
- This document describes headers-more-nginx-module v0.18
+ This document describes headers-more-nginx-module v0.19
(<http://github.com/agentzh/headers-more-nginx-module/tags>) released on
- 2 August 2012.
+ 20 November 2012.
Synopsis
# set the Server output header
@@ -237,12 +237,12 @@ Limitations
Installation
Grab the nginx source code from nginx.org (<http://nginx.org/>), for
- example, the version 1.2.1 (see nginx compatibility), and then build the
+ example, the version 1.2.4 (see nginx compatibility), and then build the
source with this module:
- wget 'http://nginx.org/download/nginx-1.2.1.tar.gz'
- tar -xzvf nginx-1.2.1.tar.gz
- cd nginx-1.2.1/
+ wget 'http://nginx.org/download/nginx-1.2.4.tar.gz'
+ tar -xzvf nginx-1.2.4.tar.gz
+ cd nginx-1.2.4/
# Here we assume you would install you nginx under /opt/nginx/.
./configure --prefix=/opt/nginx \
@@ -261,7 +261,9 @@ Installation
Compatibility
The following versions of Nginx should work with this module:
- * 1.2.x (last tested: 1.2.1)
+ * 1.3.x (last tested: 1.3.7)
+
+ * 1.2.x (last tested: 1.2.4)
* 1.1.x (last tested: 1.1.5)
@@ -278,16 +280,22 @@ Compatibility
If you find that any particular version of Nginx above 0.7.44 does not
work with this module, please consider reporting a bug.
-Report Bugs
- Although a lot of effort has been put into testing and code tuning,
- there must be some serious bugs lurking somewhere in this module. So
- whenever you are bitten by any quirks, please don't hesitate to
+Community
+ English Mailing List
+ The openresty-en (<https://groups.google.com/group/openresty-en>)
+ mailing list is for English speakers.
+
+ Chinese Mailing List
+ The openresty (<https://groups.google.com/group/openresty>) mailing list
+ is for Chinese speakers.
+
+Bugs and Patches
+ Please submit bug reports, wishlists, or patches by
- 1. send a bug report or even patches to <agentzh@gmail.com>,
+ 1. creating a ticket on the GitHub Issue Tracker
+ (<http://github.com/chaoslawful/lua-nginx-module/issues>),
- 2. or create a ticket on the issue tracking interface
- (<http://github.com/agentzh/headers-more-nginx-module/issues>)
- provided by GitHub.
+ 2. or posting to the OpenResty community.
Source Repository
Available on github at agentzh/headers-more-nginx-module
View
@@ -13,7 +13,7 @@ Name
Version
=======
-This document describes headers-more-nginx-module [v0.18](http://github.com/agentzh/headers-more-nginx-module/tags) released on 2 August 2012.
+This document describes headers-more-nginx-module [v0.19](http://github.com/agentzh/headers-more-nginx-module/tags) released on 20 November 2012.
Synopsis
========
@@ -262,12 +262,12 @@ Installation
============
Grab the nginx source code from [nginx.org](http://nginx.org/), for example,
-the version 1.2.1 (see [nginx compatibility](http://wiki.nginx.org/HttpHeadersMoreModule#Compatibility)), and then build the source with this module:
+the version 1.2.4 (see [nginx compatibility](http://wiki.nginx.org/HttpHeadersMoreModule#Compatibility)), and then build the source with this module:
- wget 'http://nginx.org/download/nginx-1.2.1.tar.gz'
- tar -xzvf nginx-1.2.1.tar.gz
- cd nginx-1.2.1/
+ wget 'http://nginx.org/download/nginx-1.2.4.tar.gz'
+ tar -xzvf nginx-1.2.4.tar.gz
+ cd nginx-1.2.4/
# Here we assume you would install you nginx under /opt/nginx/.
./configure --prefix=/opt/nginx \
@@ -286,7 +286,8 @@ Compatibility
The following versions of Nginx should work with this module:
-* **1.2.x** (last tested: 1.2.1)
+* **1.3.x** (last tested: 1.3.7)
+* **1.2.x** (last tested: 1.2.4)
* **1.1.x** (last tested: 1.1.5)
* **1.0.x** (last tested: 1.0.11)
* **0.9.x** (last tested: 0.9.4)
@@ -297,13 +298,26 @@ Earlier versions of Nginx like 0.6.x and 0.5.x will *not* work.
If you find that any particular version of Nginx above 0.7.44 does not work with this module, please consider [reporting a bug](http://wiki.nginx.org/HttpHeadersMoreModule#Report_Bugs).
-Report Bugs
-===========
+Community
+=========
+
+English Mailing List
+--------------------
+
+The [openresty-en](https://groups.google.com/group/openresty-en) mailing list is for English speakers.
+
+Chinese Mailing List
+--------------------
+
+The [openresty](https://groups.google.com/group/openresty) mailing list is for Chinese speakers.
+
+Bugs and Patches
+================
-Although a lot of effort has been put into testing and code tuning, there must be some serious bugs lurking somewhere in this module. So whenever you are bitten by any quirks, please don't hesitate to
+Please submit bug reports, wishlists, or patches by
-1. send a bug report or even patches to <agentzh@gmail.com>,
-1. or create a ticket on the [issue tracking interface](http://github.com/agentzh/headers-more-nginx-module/issues) provided by GitHub.
+1. creating a ticket on the [GitHub Issue Tracker](http://github.com/chaoslawful/lua-nginx-module/issues),
+1. or posting to the [OpenResty community](http://wiki.nginx.org/HttpHeadersMoreModule#Community).
Source Repository
=================
@@ -6,7 +6,7 @@
= Version =
-This document describes headers-more-nginx-module [http://github.com/agentzh/headers-more-nginx-module/tags v0.18] released on 2 August 2012.
+This document describes headers-more-nginx-module [http://github.com/agentzh/headers-more-nginx-module/tags v0.19] released on 20 November 2012.
= Synopsis =
@@ -246,12 +246,12 @@ See [[#more_set_input_headers|more_set_input_headers]] for more details.
= Installation =
Grab the nginx source code from [http://nginx.org/ nginx.org], for example,
-the version 1.2.1 (see [[#Compatibility|nginx compatibility]]), and then build the source with this module:
+the version 1.2.4 (see [[#Compatibility|nginx compatibility]]), and then build the source with this module:
<geshi lang="bash">
- wget 'http://nginx.org/download/nginx-1.2.1.tar.gz'
- tar -xzvf nginx-1.2.1.tar.gz
- cd nginx-1.2.1/
+ wget 'http://nginx.org/download/nginx-1.2.4.tar.gz'
+ tar -xzvf nginx-1.2.4.tar.gz
+ cd nginx-1.2.4/
# Here we assume you would install you nginx under /opt/nginx/.
./configure --prefix=/opt/nginx \
@@ -269,7 +269,8 @@ Also, this module is included and enabled by default in the [http://openresty.or
The following versions of Nginx should work with this module:
-* '''1.2.x''' (last tested: 1.2.1)
+* '''1.3.x''' (last tested: 1.3.7)
+* '''1.2.x''' (last tested: 1.2.4)
* '''1.1.x''' (last tested: 1.1.5)
* '''1.0.x''' (last tested: 1.0.11)
* '''0.9.x''' (last tested: 0.9.4)
@@ -280,12 +281,22 @@ Earlier versions of Nginx like 0.6.x and 0.5.x will ''not'' work.
If you find that any particular version of Nginx above 0.7.44 does not work with this module, please consider [[#Report Bugs|reporting a bug]].
-= Report Bugs =
+= Community =
-Although a lot of effort has been put into testing and code tuning, there must be some serious bugs lurking somewhere in this module. So whenever you are bitten by any quirks, please don't hesitate to
+== English Mailing List ==
-# send a bug report or even patches to <agentzh@gmail.com>,
-# or create a ticket on the [http://github.com/agentzh/headers-more-nginx-module/issues issue tracking interface] provided by GitHub.
+The [https://groups.google.com/group/openresty-en openresty-en] mailing list is for English speakers.
+
+== Chinese Mailing List ==
+
+The [https://groups.google.com/group/openresty openresty] mailing list is for Chinese speakers.
+
+= Bugs and Patches =
+
+Please submit bug reports, wishlists, or patches by
+
+# creating a ticket on the [http://github.com/chaoslawful/lua-nginx-module/issues GitHub Issue Tracker],
+# or posting to the [[#Community|OpenResty community]].
= Source Repository =

0 comments on commit 27bcbd2

Please sign in to comment.