Permalink
Browse files

fixed the Installation section in docs: we require ngx_devel_kit.

  • Loading branch information...
agentzh committed Aug 16, 2011
1 parent 3c7ed61 commit 3c1082b222ba600db9c96edec92e19d16536c010
Showing with 16 additions and 3 deletions.
  1. +8 −1 README
  2. +4 −1 README.markdown
  3. +4 −1 doc/NginxHttpSetMiscModule.wiki
View
9 README
@@ -834,14 +834,21 @@ Installation
# Here we assume you would install you nginx under /opt/nginx/.
$ ./configure --prefix=/opt/nginx \
+ --add-module=/path/to/ngx_devel_kit \
--add-module=/path/to/set-misc-nginx-module
$ make -j2
$ make install
Download the latest version of the release tarball of this module from
set-misc-nginx-module file list
- (<http://github.com/agentzh/set-misc-nginx-module/downloads>).
+ (<http://github.com/agentzh/set-misc-nginx-module/downloads>), and the
+ latest tarball for ngx_devel_kit
+ (<https://github.com/simpl/ngx_devel_kit>) from its file list
+ (<https://github.com/simpl/ngx_devel_kit/downloads>).
+
+ Also, this module is included and enabled by default in the
+ ngx_openresty bundle (<http://openresty.org/>).
Compatibility
The following versions of Nginx should work with this module:
View
@@ -826,13 +826,16 @@ the version 1.0.5 (see [nginx compatibility](http://wiki.nginx.org/NginxHttpSetM
# Here we assume you would install you nginx under /opt/nginx/.
$ ./configure --prefix=/opt/nginx \
+ --add-module=/path/to/ngx_devel_kit \
--add-module=/path/to/set-misc-nginx-module
$ make -j2
$ make install
-Download the latest version of the release tarball of this module from [set-misc-nginx-module file list](http://github.com/agentzh/set-misc-nginx-module/downloads).
+Download the latest version of the release tarball of this module from [set-misc-nginx-module file list](http://github.com/agentzh/set-misc-nginx-module/downloads), and the latest tarball for [ngx_devel_kit](https://github.com/simpl/ngx_devel_kit) from its [file list](https://github.com/simpl/ngx_devel_kit/downloads).
+
+Also, this module is included and enabled by default in the [ngx_openresty bundle](http://openresty.org/).
Compatibility
=============
@@ -800,13 +800,16 @@ the version 1.0.5 (see [[#Compatibility|nginx compatibility]]), and then build t
# Here we assume you would install you nginx under /opt/nginx/.
$ ./configure --prefix=/opt/nginx \
+ --add-module=/path/to/ngx_devel_kit \
--add-module=/path/to/set-misc-nginx-module
$ make -j2
$ make install
</geshi>
-Download the latest version of the release tarball of this module from [http://github.com/agentzh/set-misc-nginx-module/downloads set-misc-nginx-module file list].
+Download the latest version of the release tarball of this module from [http://github.com/agentzh/set-misc-nginx-module/downloads set-misc-nginx-module file list], and the latest tarball for [https://github.com/simpl/ngx_devel_kit ngx_devel_kit] from its [https://github.com/simpl/ngx_devel_kit/downloads file list].
+
+Also, this module is included and enabled by default in the [http://openresty.org/ ngx_openresty bundle].
= Compatibility =

0 comments on commit 3c1082b

Please sign in to comment.