Skip to content
This repository

Can't build on Archlinux since a few weeks #117

Closed
equinoxefr opened this Issue May 18, 2012 · 2 comments

2 participants

Pierre DOUCET Marius Kintel
Pierre DOUCET

Hi,

I can't build openscad ( 201112 or git ) on lastest Archlinux with new versions of dependencies:
eigen2 2.0.17
cgal 4.0
qt 4.8.1
opencsg 1.3.2

When i'm trying to build, i have this error:

/usr/include/CGAL/Mesh_2/Do_not_refine_edges.h:83:7: note: use ‘this->is_locally_conform’ instead
make: *** [objects/dxftess.o] Erreur 1

Full log here: http://pastebin.com/ZZzmTn4w

Any ideas ?

Regards

Pierre

Marius Kintel
Owner
kintel commented May 18, 2012

Look at the mailing list discussion about Ubuntu and gcc-4.7. This looks like the same problem.

Pierre DOUCET

Great !

You're right, i found this patch to apply on CGAL. Now everything is OK !

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sci-mathematics/cgal/files/cgal-4.0-gcc47.patch?view=markup

Thank's

Pierre

Pierre DOUCET equinoxefr closed this May 18, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.