Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Can't update openscad #307

Closed
SKelem opened this Issue · 11 comments

4 participants

@SKelem

I get the message:
Can't install openscad_2013.01+dfsg-2ubuntu1+precise: no package provides libboost-filesystem1.46.1 >= 1.46.1-1
I have:
openscad 2011.12-3ubuntu3
libboost-filesystem1.49.0-3.1ubuntu1.2
libboost-filesystem1.50.0-1

Both of those seem to be > 1.46.1 and > 1.46.1-1.

It wants to upgrade to openscad_2013.01+dfsg-2ubuntu1+precise.

Ubuntu 12.10 x86-64

@chrysn

12.10 is quantal, you are trying to install the packages for precise. please use the " 2013.01+dfsg-2ubuntu2" version. (i know, the version names in the ppa are a little messed up).

the libboost-filessytem packages have versions in their file names, which means that a libboost-filesystem1.49 won't satisfy libboost-filesystem1.46.1 >= 1.46.1-1. i strongly assume that this happens on purpose (because the abi changes); those packages are one of the important reasons to use packages compiled for your very distribution version.

@kintel
Owner

Closing as no further feedback was received.

@kintel kintel closed this
@SKelem
@kintel
Owner

I thought chrysn's answer was good enough. Apparently, this is still confusing.
chrysn: Do you have an idea how to make installations less painful? Once I understand it myself, I could write it up on the web site.

@kintel kintel reopened this
@chrysn

whether you need to change your sources.list depends on what's in it :-) -- paste it here, and i can have a look. (also, if there are any /etc/apt/sources.list.d/* files, post them too).

@kintel: this shouldn't be painful, if you follow the very lines on the openscad website, things should just work. i assume that in this case, there is a discrepancy between the ubuntu version configured for the ppa and the rest of the system, but i can only tell once i see the sources.list.

@kintel
Owner

SKelem: Any news on this from your side?

@kintel
Owner

No news - assuming this is resolved

@kintel kintel closed this
@SKelem

I guess you can close it. I've given up. I'll try using something else.

@kintel
Owner

It was only closed because of lack of feedback. You've got the only known broken system and chrysn cannot help you fix it unless he gets the necessary info about your Ubuntu setup (see his last message).

@donbright
Collaborator

building from source should be relatively easy, ive done it on 12.04 and 12.10

        cd openscad
        source ./scripts/setenv-unibuild.sh
        ./scripts/uni-build-dependencies.sh
        qmake-qt4 && make
@SKelem

I updated to Ubuntu 13.04, and have had my hands full fixing all the stuff that broke.

I just tried adding the repositories, installing openscad, and...it works!

Whatever was broken for me in 12.10 is now working. So, this can be closed! Yippee!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.