Fix Qt 4.8.4 build when using Xcode 4.6's clang. #316

Closed
wants to merge 1 commit into
from

Projects

None yet

2 participants

@nico
Contributor
nico commented Mar 23, 2013

Backports https://bugreports.qt-project.org/browse/QTBUG-29373 .

./scripts/macosx-build-dependencies.sh -c finishes successfully for me with this change. Building without -c fails somewhere in boost. You probably want to turn on -c by default on mac, or mention on the README that it's required at least with recent Xcode versions.

@kintel
Member
kintel commented Mar 25, 2013

I already had this patch in a different branch, which has now been merged into master.

Could you clarify what issues you have with boost and Xcode 4.6 without clang?
I'm using Xcode 4.6 with gcc as my main compiler, but I'm still on 10.7, which could be different from your setup.
Perhaps open a new issue for the boost thing and close this one?

@kintel
Member
kintel commented Mar 25, 2013

oh, issue #315 deals with boost compile issues (catching up on issues..)
Closing this..

@kintel kintel closed this Mar 25, 2013
@nico
Contributor
nico commented Mar 25, 2013

I mentioned in issue #315 that I needed this patch to build with Xcode 4.6. I think pull request needs to be merged.

@kintel
Member
kintel commented Mar 25, 2013

I did merge an equivalent patch which was lying around in another branch. Could you check if it fixes your issue?
I'd also like to fix the gcc issue - will handle that in #315 once I can reproduce it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment