New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Linux Centos 7 - Jetty 9.4.7 - bimserver-1.4.0-FINAL-2015-11-04 .war - SETUP #666

Open
Elsa-E4-user opened this Issue Dec 4, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@Elsa-E4-user

Elsa-E4-user commented Dec 4, 2017

Please use your code to escape code and use the "Preview" button to see whether your issue is readable. Also, when relevant, please note your BIMserver version.
When posting logfiles, please post the actual text, and not screenshots of the log files. Also logfiles with no error messages whatsoever are usually not very useful.

Environment:
Linux 3.10.0-514.26.2.el7.x86_64
Jetty jetty-distribution-9.4.7.v20170914
Jetty service env variable:
JETTY_HOME=
JETTY_BASE=
JETTY_USER=jetty
JETTY_PORT=<MY-PORT
JETTY_HOST=
JETTY_RUN=<MY_RUN_DIR>
TMPDIR=

Jetty services configured:

deploy
http
jsp
logging-log4j
server
servlet
websocket

Server installation steps followed:

  1. copied bimserver-1.4.0-FINAL-2015-11-04 .war to $JETTY_BASE/webapps as ROOT.war
  2. started jetty service
  • a $TMPDIR/jetty-{MY-IP}-{MY-PORT}-ROOT.war-_-any-{UNIQUEID}.dir/ two folder are created: jsp and webapp, last one with the content of ROOT.war
  • a FAILED jetty service start message is displayed after a while (maybe timeout reached for injected service reply)
  • meanwhile in $TMPDIR/jetty-{MY-IP}-{MY-PORT}-ROOT.war-_-any-{UNIQUEID}.dir/webapp/WEB-INF/logs/bimserver.log BIMServer continue to output trace of startup process (e.g. DB creation) until the INFO message: INFO Changing server state to NOT_SETUP (org.bimserver.ServerInfoManager.java:113) is printed
  • restarted service [sudo service jetty restart] (reported as FAILED again)
  • opening a web browser using {MY-IP}:{MY-PORT} URL the configuration page appears asking for site address, administrator name, Administrator email and password
  • filling fields ans clicking "setup" button give a "Login successful" message in hte top right corner but the screen do not change (continue to show setup page)

logfile content at this stage:

22-11-2017 15:39:56 INFO WebSocket open (org.bimserver.servlets.websockets.jsr356.Jsr356Impl.java:63)
22-11-2017 15:39:56 ERROR (org.bimserver.servlets.websockets.jsr356.Jsr356Impl.java:70)
java.lang.NullPointerException
at org.bimserver.servlets.websockets.jsr356.Jsr356Impl.onOpen(Jsr356Impl.java:66)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.jetty.websocket.common.events.annotated.CallableMethod.call(CallableMethod.java:71)
at org.eclipse.jetty.websocket.jsr356.annotations.OnOpenCallable.call(OnOpenCallable.java:54)
at org.eclipse.jetty.websocket.jsr356.annotations.JsrEvents.callOpen(JsrEvents.java:170)
at org.eclipse.jetty.websocket.jsr356.endpoints.JsrAnnotatedEventDriver.onConnect(JsrAnnotatedEventDriver.java:195)
at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.openSession(AbstractEventDriver.java:233)
at org.eclipse.jetty.websocket.jsr356.endpoints.AbstractJsrEventDriver.openSession(AbstractJsrEventDriver.java:104)
at org.eclipse.jetty.websocket.common.WebSocketSession.open(WebSocketSession.java:504)
at org.eclipse.jetty.websocket.common.WebSocketSession.onOpened(WebSocketSession.java:433)
at org.eclipse.jetty.io.AbstractConnection.onOpen(AbstractConnection.java:200)
at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onOpen(AbstractWebSocketConnection.java:566)
at org.eclipse.jetty.io.AbstractEndPoint.upgrade(AbstractEndPoint.java:432)
at org.eclipse.jetty.server.HttpConnection.onCompleted(HttpConnection.java:376)
at org.eclipse.jetty.server.HttpChannel.onCompleted(HttpChannel.java:651)
at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:459)
at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:251)
at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:279)
at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:104)
at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:124)
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:247)
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.produce(EatWhatYouKill.java:140)
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:131)
at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:243)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:679)
at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:597)
at java.lang.Thread.run(Thread.java:748)
If page is reloaded the Login form appears: but Sign in do not get to anywhere.
Logfile content:

22-11-2017 15:48:40 DEBUG org.bimserver.AuthInterface.getLoggedInUser 2ms (org.bimserver.JsonHandler.java:150)
22-11-2017 15:48:40 INFO WebSocket open (org.bimserver.servlets.websockets.jsr356.Jsr356Impl.java:63)
22-11-2017 15:48:40 ERROR (org.bimserver.servlets.websockets.jsr356.Jsr356Impl.java:70)
java.lang.NullPointerException
at org.bimserver.servlets.websockets.jsr356.Jsr356Impl.onOpen(Jsr356Impl.java:66)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.jetty.websocket.common.events.annotated.CallableMethod.call(CallableMethod.java:71)
at org.eclipse.jetty.websocket.jsr356.annotations.OnOpenCallable.call(OnOpenCallable.java:54)
at org.eclipse.jetty.websocket.jsr356.annotations.JsrEvents.callOpen(JsrEvents.java:170)
at org.eclipse.jetty.websocket.jsr356.endpoints.JsrAnnotatedEventDriver.onConnect(JsrAnnotatedEventDriver.java:195)
at org.eclipse.jetty.websocket.common.events.AbstractEventDriver.openSession(AbstractEventDriver.java:233)
at org.eclipse.jetty.websocket.jsr356.endpoints.AbstractJsrEventDriver.openSession(AbstractJsrEventDriver.java:104)
at org.eclipse.jetty.websocket.common.WebSocketSession.open(WebSocketSession.java:504)
at org.eclipse.jetty.websocket.common.WebSocketSession.onOpened(WebSocketSession.java:433)
at org.eclipse.jetty.io.AbstractConnection.onOpen(AbstractConnection.java:200)
at org.eclipse.jetty.websocket.common.io.AbstractWebSocketConnection.onOpen(AbstractWebSocketConnection.java:566)
at org.eclipse.jetty.io.AbstractEndPoint.upgrade(AbstractEndPoint.java:432)
at org.eclipse.jetty.server.HttpConnection.onCompleted(HttpConnection.java:376)
at org.eclipse.jetty.server.HttpChannel.onCompleted(HttpChannel.java:651)
at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:459)
at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:251)
at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:279)
at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:104)
at org.eclipse.jetty.io.ChannelEndPoint$2.run(ChannelEndPoint.java:124)
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(EatWhatYouKill.java:247)
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.produce(EatWhatYouKill.java:140)
at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.run(EatWhatYouKill.java:131)
at org.eclipse.jetty.util.thread.ReservedThreadExecutor$ReservedThread.run(ReservedThreadExecutor.java:243)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:679)
at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:597)
at java.lang.Thread.run(Thread.java:748)

Only Once, opening the browser before restarting the service, the following error appeared (jetty service not restarted after BIMserver installation):
bim-server error2

Any suggestion?

PS Server page opened both using local firefox browser. or remote chrome browser

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment