New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

bimserverapi is not defined on new server. #672

Closed
alfredorods opened this Issue Dec 22, 2017 · 11 comments

Comments

Projects
None yet
3 participants
@alfredorods

alfredorods commented Dec 22, 2017

Hi comunity, i instaled bimserver a few times and always bimserver work great, but in this moment i'm trying to install it in a new server and i get this error:

bimserverapi is not defined

when i saw the installation the plugin was installed successfully.

bimapi

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Jan 5, 2018

Member

Are you using your own version of GUI?

Member

rubendel commented Jan 5, 2018

Are you using your own version of GUI?

@alfredorods

This comment has been minimized.

Show comment
Hide comment
@alfredorods

alfredorods Jan 5, 2018

Hi Ruben, not i'm using the war file donwloaded from the releases page.

alfredorods commented Jan 5, 2018

Hi Ruben, not i'm using the war file donwloaded from the releases page.

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Jan 5, 2018

Member

If you go to the base address, does it list the javascriptapi?

Member

rubendel commented Jan 5, 2018

If you go to the base address, does it list the javascriptapi?

@alfredorods

This comment has been minimized.

Show comment
Hide comment
@alfredorods

alfredorods Jan 5, 2018

This list? yes it is.

image

alfredorods commented Jan 5, 2018

This list? yes it is.

image

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Jan 5, 2018

Member

1.5.76, that is a very old version, every new installation will download the latest versions of every plugin you select. Those are probably not compatible with 1.5.76.

Member

rubendel commented Jan 5, 2018

1.5.76, that is a very old version, every new installation will download the latest versions of every plugin you select. Those are probably not compatible with 1.5.76.

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Jan 5, 2018

Member

Also the subpath has a tendency to not work, deploying as ROOT.war is the preferred way.

Member

rubendel commented Jan 5, 2018

Also the subpath has a tendency to not work, deploying as ROOT.war is the preferred way.

@Erbrand

This comment has been minimized.

Show comment
Hide comment
@Erbrand

Erbrand Jan 9, 2018

Hi,

here I get the same issue running the 1.5.92 :

image
image

the web-container is Tomcat 8.5.24

Erbrand commented Jan 9, 2018

Hi,

here I get the same issue running the 1.5.92 :

image
image

the web-container is Tomcat 8.5.24

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Jan 10, 2018

Member

Deploy as ROOT.war

Member

rubendel commented Jan 10, 2018

Deploy as ROOT.war

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Jan 12, 2018

Member

Newest version of BIMvie.ws and the JavaScriptAPI now support running on non ROOT path as well.

Member

rubendel commented Jan 12, 2018

Newest version of BIMvie.ws and the JavaScriptAPI now support running on non ROOT path as well.

@alfredorods

This comment has been minimized.

Show comment
Hide comment
@alfredorods

alfredorods Jan 26, 2018

Hey Rubendel thanks for your help.. i'have another doubt.. how can i install and old plugin of javascript api? because when i install i only can see 3 versions of the javascript API.. and i need see and install an old version.. i see in the repository the releases and i can download the version that i need but i don't know how can i install this version.

Thanks.

alfredorods commented Jan 26, 2018

Hey Rubendel thanks for your help.. i'have another doubt.. how can i install and old plugin of javascript api? because when i install i only can see 3 versions of the javascript API.. and i need see and install an old version.. i see in the repository the releases and i can download the version that i need but i don't know how can i install this version.

Thanks.

@rubendel

This comment has been minimized.

Show comment
Hide comment
@rubendel

rubendel Feb 6, 2018

Member

You could do that using the API of BIMserver, but I don't recommend it because usually only the latest version of everything kind of works together.

Member

rubendel commented Feb 6, 2018

You could do that using the API of BIMserver, but I don't recommend it because usually only the latest version of everything kind of works together.

@rubendel rubendel closed this Feb 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment