New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Remove EGD support or make EGD support configurable #296

Closed
Sp1l opened this Issue May 31, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@Sp1l
Copy link
Contributor

Sp1l commented May 31, 2015

The next release of OpenSSL 1.0.2 still seems to contain code supporting the Perl Entropy Gathering Daemon. No current platform requires EGD, all platforms have a far superior and more secure source of entropy.

OS EGD needed until OS released End-of-support
IRIX 6.5.19 Feb 2003 Dec 2013
Solaris 2.6 Jul 1997 Jul 2006
AIX 5.2 Oct 2002 Apr 2009
Tru64 5.1B Sep 2002 Dec 2012
HP-UX 11i v2 Sep 2003 Dec 2015

"Legacy platforms that are unlikely to have wide deployment will be removed from the code." suggests that you no longer need to support systems requiring Perl EGD as source of randomness and I believe this should be removed.

@richsalz

This comment has been minimized.

Copy link
Contributor

richsalz commented Feb 25, 2016

done.

@richsalz richsalz closed this Feb 25, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment