Permalink
Browse files

Switch to ranges for dependencies to avoid conflicts in consumers

tripleo-quickstart lists browbeat as a dependency and too strict
requirements can cause conflicts. Avoid case where ansible version
used by tripleo was downgraded to a buggy old version mentioned
by browbeat.

To be clear: if needed, it would be expected to add version capping
here. If we know that ansible 2.9 will break the code it would be
wise to add "<2.9" to it. Adding testing with newer versions would
be subject of another change.

If you add a capping please always add a link to the bug that made
it necessary, it helps a lot later.

Change-Id: I163a7088d687dbaf0a04f4b9c2f706652a92c7c4
  • Loading branch information...
ssbarnea committed Oct 26, 2018
1 parent 482ebc6 commit 1c041315839f4024d63559c546084ebb7086f907
Showing with 7 additions and 5 deletions.
  1. +7 −5 requirements.txt
View
@@ -1,8 +1,10 @@
ansible==2.4.1
# to avoid dependency conflicts, try to use ranges, eventually banning a
# buggy minor version (!=) or capping (<) once you have proof it breaks.
ansible>=2.4.1
numpy
elasticsearch
grafyaml==0.0.7
grafyaml>=0.0.7
openstacksdk
python-dateutil==2.4.2
python-openstackclient==3.11.0
pykwalify==1.6.0
python-dateutil>=2.4.2
python-openstackclient>=3.11.0
pykwalify>=1.6.0

0 comments on commit 1c04131

Please sign in to comment.