New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Latest build on Mac: Icon bounces up and down a little, then nothing. #573

Closed
tkpwaeub opened this Issue Aug 7, 2016 · 6 comments

Comments

Projects
None yet
5 participants
@tkpwaeub

tkpwaeub commented Aug 7, 2016

Classification: Crash/Hang/Data Loss

Reproducibility: Always

I just installed the latest weekly build, and then when I start Plover, I first get this message:

screen shot 2016-08-07 at 2 04 06 pm

When I select "Open" the icon bounces up and down a few times, then nothing happens.

@morinted

This comment has been minimized.

Member

morinted commented Aug 8, 2016

Some questions:

  • Did you drag the application into the Applications folder first?
  • What version of OS X are you running?
  • What sort of output do you get if you try running the .app from the command-line? E.g. ./plover.app/Contents/MacOS/Plover
@avh4

This comment has been minimized.

avh4 commented Sep 4, 2016

I am having the same problem. If I click on Plover to open it, it simply does nothing.

If I run /Applications/plover.app/Contents/MacOS/Plover, the Plover starts, and prints this in the terminal:

Sep  3 21:14:36  Plover[58822] <Notice>: 2016-09-03 21:14:36,589 [MainThread] ERROR: engine initialization failed
Sep  3 21:14:36  Plover[58822] <Notice>: Traceback (most recent call last):
Sep  3 21:14:36  Plover[58822] <Notice>:   File "plover/gui/main.pyc", line 241, in __init__
Sep  3 21:14:36  Plover[58822] <Notice>:   File "plover/app.pyc", line 37, in init_engine
Sep  3 21:14:36  Plover[58822] <Notice>:   File "plover/app.pyc", line 57, in update_engine
Sep  3 21:14:36  Plover[58822] <Notice>:   File "plover/app.pyc", line 179, in set_machine
Sep  3 21:14:36  Plover[58822] <Notice>:   File "plover/machine/keyboard.pyc", line 56, in start_capture
Sep  3 21:14:36  Plover[58822] <Notice>:   File "plover/oslayer/osxkeyboardcontrol.pyc", line 228, in __init__
Sep  3 21:14:36  Plover[58822] <Notice>: Exception: Enable access for assistive devices.

I do have Plover added in the System Preferences:

screen shot 2016-09-03 at 9 19 21 pm

This is on OS X 10.11.6

Plover 3.0.0 works, but weekly-v3.0.0+199.g2396c74 and weekly-v3.0.0+110.gc240d71 both have the problem described here.

@morinted

This comment has been minimized.

Member

morinted commented Sep 8, 2016

@avh4 You need to re-add every new download of Plover to accessibility settings. It may help to remove the old entry and add the weeklies.

@tkpwaeub I'm afraid I don't have enough information without filling in the issue template:

https://raw.githubusercontent.com/openstenoproject/plover/master/.github/ISSUE_TEMPLATE.md

It would also help if you can get the log output when you try running from the commandline. For example, place Plover.app into your folder and then run:

cd ~
./Plover.app/Contents/MacOS/Plover

@morinted morinted closed this Sep 8, 2016

@sammy-nes

This comment has been minimized.

sammy-nes commented Oct 21, 2016

Hi,

I am new to the Plover community, and would like first to say thank you for providing such a nice program!
I have the same issues described, although for me I am running on the latest OS Sierra 10.12.
Same, when I launch the app, the icon bounces on the dock and then disappears, with the following window:

..............
Traceback (most recent call last):
File "/Applications/plover.app/Contents/Resources/main.py", line 84, in main
File "plover/gui/main.pyc", line 47, in init
File "wx/_core.pyc", line 8628, in init
File "wx/_core.pyc", line 8196, in _BootstrapApp
File "plover/gui/main.pyc", line 55, in OnInit
File "plover/gui/main.pyc", line 228, in init
File "plover/gui/main.pyc", line 368, in init
File "plover/oslayer/osxkeyboardcontrol.pyc", line 310, in init
File "plover/oslayer/osxkeyboardlayout.pyc", line 128, in init
File "plover/oslayer/osxkeyboardlayout.pyc", line 150, in _update_layout
File "plover/oslayer/osxkeyboardlayout.pyc", line 251, in _get_layout
File "plover/oslayer/osxkeyboardlayout.pyc", line 441, in _parse_layout
KeyError: 1
.................

Any leads about that?

@benoit-pierre

This comment has been minimized.

Member

benoit-pierre commented Oct 22, 2016

@sammy-nes: it looks like something goes wrong when trying to parse you're keyboard layout. Can you open a new issue with the relevant information (Plover version, keyboard layout being used)?

@morinted

This comment has been minimized.

Member

morinted commented Oct 25, 2016

You may have to change to a Qwerty/US layout to use Plover for now. This is
a bug with symbolic languages like Korean and Japanese.

On Oct 21, 2016 12:17 PM, "sammy-nes" notifications@github.com wrote:

Hi,

I am new to the Plover community, and would like first to say thank you
for providing such a nice program!
I have the same issues described, although for me I am running on the
latest OS Sierra 10.12.
Same, when I launch the app, the icon bounces on the dock and then
disappears, with the following window:

..............
Traceback (most recent call last):
File "/Applications/plover.app/Contents/Resources/main.py", line 84, in
main
File "plover/gui/main.pyc", line 47, in init
File "wx/_core.pyc", line 8628, in init
File "wx/

_core.pyc", line 8196, in BootstrapApp File "plover/gui/main.pyc", line
55, in OnInit File "plover/gui/main.pyc", line 228, in _init
File "plover/gui/main.pyc", line 368, in init
File "plover/oslayer/osxkeyboardcontrol.pyc", line 310, in init
File "plover/oslayer/osxkeyboardlayout.pyc", line 128, in init
File "plover/oslayer/osxkeyboardlayout.pyc", line 150, in _update_layout
File "plover/oslayer/osxkeyboardlayout.pyc", line 251, in _get_layout
File "plover/oslayer/osxkeyboardlayout.pyc", line 441, in _parse_layout
KeyError: 1
.................

Any leads about that?


You are receiving this because you modified the open/close state.
Reply to this email directly, view it on GitHub
#573 (comment),
or mute the thread
https://github.com/notifications/unsubscribe-auth/AFkgSjvlhhbzgOj-CRXwlYqs9m4yCHX3ks5q2OWegaJpZM4JejT4
.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment