Skip to content

@lonvia lonvia released this Oct 25, 2019 · 23 commits to master since this release

This release brings some improvements to the internal database structure that further reduce the size of the database. It also contains a fix for osm2pgsql where the import sometimes runs out of memory, especially when no flatnode files are used. If you plan to import a new database without flatnode files, an upgrade is strongly recommended.

As usual, there are some smaller improvements to documentation and the search algorithm. Details can be found in Changelog.md.

Please note that starting with this vesion PostgreSQL >= 9.3, PostGIS >= 2.2 and PHP >= 7.0 are required.

If you want to update from 3.x.x, there is a database migration path described in the migration guide. Migrating from 3.1.0 can be done without problems. When updating from 3.0.x, a full database reimport is strongly recommended. Updating from older releases is only possible with a database reimport.

Assets 2
You can’t perform that action at this time.