Permalink
Fetching contributors…
Cannot retrieve contributors at this time
84 lines (83 sloc) 2.66 KB
{
"name": "iD",
"version": "2.0.1",
"description": "A friendly editor for OpenStreetMap",
"main": "iD.js",
"repository": "openstreetmap/iD",
"keywords": [
"editor",
"openstreetmap"
],
"license": "ISC",
"scripts": {
"all": "npm-run-all -s clean build dist",
"build": "node build.js && node development_server.js",
"clean": "shx rm -f dist/*.js dist/*.map dist/*.css dist/img/*.svg",
"dist": "npm-run-all -p dist:**",
"dist:css": "shx cat css/reset.css css/map.css css/app.css > dist/iD.css",
"dist:mapillary": "shx mkdir -p dist/mapillary-js && shx cp -R node_modules/mapillary-js/dist/* dist/mapillary-js/",
"dist:min": "uglifyjs dist/iD.js -c -m -o dist/iD.min.js",
"dist:svg:maki": "svg-sprite --symbol --symbol-dest . --symbol-sprite dist/img/maki-sprite.svg node_modules/maki/src/*.svg",
"dist:svg:id": "node svg/spriteify.js --svg svg/iD-sprite.src.svg --json svg/iD-sprite.json > dist/img/iD-sprite.svg",
"imagery": "node data/update_imagery",
"lint": "eslint *.js js/id test/spec modules",
"prepublish": "npm run all",
"start": "node development_server.js develop",
"test": "npm-run-all -s lint build test:**",
"test:phantom": "phantomjs node_modules/mocha-phantomjs-core/mocha-phantomjs-core.js test/index.html spec",
"translations": "node data/update_locales"
},
"dependencies": {
"diacritics": "1.2.3",
"lodash": "4.17.2",
"marked": "0.3.6",
"osm-auth": "1.0.1",
"rbush": "2.0.1",
"sexagesimal": "0.5.0",
"togeojson": "0.16.0",
"wmf-sitematrix": "0.1.3"
},
"devDependencies": {
"brfs": "1.4.3",
"chai": "~3.5.0",
"d3": "4.4.0",
"ecstatic": "~2.1.0",
"editor-layer-index": "osmlab/editor-layer-index.git#gh-pages",
"gaze": "~1.1.1",
"eslint": "~3.11.0",
"glob": "~7.1.0",
"happen": "~0.3.1",
"js-yaml": "~3.7.0",
"jsonschema": "~1.1.0",
"json-stable-stringify": "~1.0.1",
"maki": "0.5.0",
"mapillary-js": "2.1.0",
"minimist": "~1.2.0",
"mocha": "~3.2.0",
"mocha-phantomjs-core": "~2.1.0",
"name-suggestion-index": "0.1.1",
"npm-run-all": "~3.1.1",
"phantomjs-prebuilt": "~2.1.11",
"request": "~2.79.0",
"rollup": "0.36.4",
"rollup-plugin-commonjs": "5.0.5",
"rollup-plugin-json": "2.0.2",
"rollup-plugin-node-resolve": "2.0.0",
"shelljs": "~0.7.5",
"shx": "~0.2.1",
"sinon": "~1.17.5",
"sinon-chai": "~2.8.0",
"smash": "0.0",
"svg-sprite": "1.3.6",
"uglify-js": "~2.7.0",
"xml2js": "~0.4.17",
"xmlbuilder": "~8.2.2"
},
"greenkeeper": {
"ignore": ["maki"],
"label": "chore-greenkeeper"
},
"engines": {
"node": ">=4.0.0"
}
}