Skip to content
This repository has been archived by the owner. It is now read-only.

embed.html does not handle Transport and MaqQuest base layers #4291

Closed
openstreetmap-trac opened this issue Jul 23, 2021 · 1 comment
Closed

embed.html does not handle Transport and MaqQuest base layers #4291

openstreetmap-trac opened this issue Jul 23, 2021 · 1 comment

Comments

@openstreetmap-trac
Copy link

@openstreetmap-trac openstreetmap-trac commented Jul 23, 2021

Reporter: thirteen
[Submitted to the original trac issue database at 2.20pm, Monday, 12th March 2012]

[http://www.openstreetmap.org/export/embed.html] [[BR]]
is lacking support for layer=transportmap and layer=mapquest arguments in the embedded javascript function init().

Suggested fix:
See the attached patch file. The added map layer code is taken from the slippy map code.

Reproduction steps:[[BR]]

  1. Goto [http://www.openstreetmap.org] [[BR]]
  2. Open sidebar and choose either Transport Map or MapQuest Open as base layer[[BR]]
  3. Click on Export and select format Embeddable HTML[[BR]]
  4. Paste the generated HTML in some website and open it[[BR]]
  5. Result: The embedded map is empty[[BR]]
@openstreetmap-trac
Copy link
Author

@openstreetmap-trac openstreetmap-trac commented Jul 23, 2021

Author: TomH
[Added to the original trac issue at 10.47pm, Monday, 12th March 2012]

Committed - will deploy shortly.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant