Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

[Build] Test build OpenTK with mono 3.2.6 and 2.10.11

Squashed commit of the following:

commit 15ec03c
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 15:53:18 2014 +0100

    [Build] Fixed missing '' typo

commit 9e3dcad
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 15:27:07 2014 +0100

    [Build] Install mono either from pwd or from mounted /Volume

commit b7303b6
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 15:21:40 2014 +0100

    [Build] Do not stop build when wget fails

    The build stops iff no valid mono framework can be installed

commit 875c232
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 15:13:08 2014 +0100

    [Build] Fix 3.2.x and 2.10.x mono download urls

commit 7bcbc78
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 11:58:57 2014 +0100

    [Build] Use .pkg file for mono installation on Travis

commit 60fef5a
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 11:43:12 2014 +0100

    [Build] Detect *.yml as text files

commit 7fb4285
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 11:40:07 2014 +0100

    [Build] Move first xbuild run to pre-build scripts

commit e1cfcf7
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 11:38:19 2014 +0100

    [Build] Fixed mono 3.2.6 download url

commit c694184
Author: thefiddler <stapostol@gmail.com>
Date:   Mon Feb 24 11:32:16 2014 +0100

    [Build] Run xbuild twice for GlobalAssemblyInfo.cs

    This works around an issue in xbuild, where pre-build events
    are not resolved correctly. The first run generates
    GlobalAssemblyInfo.cs; the second run actually builds the project
  • Loading branch information...
commit a944318f27d6bb4fc08fa30c604bc5908598e424 1 parent 4884c65
@thefiddler thefiddler authored
Showing with 6 additions and 3 deletions.
  1. +1 −0  .gitattributes
  2. +5 −3 .travis.yml
View
1  .gitattributes
@@ -13,6 +13,7 @@
*.tm text
*.glsl text
*.resx text
+*.yml text
*.dll binary
*.exe binary
View
8 .travis.yml
@@ -8,9 +8,11 @@ env:
- MONO_VER="3.2.6"
before_install:
- - wget "http://download.mono-project.com/archive/${MONO_VER}/macos-10-x86/MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.dmg"
- - hdid "MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.dmg"
- - sudo installer -pkg "/Volumes/Mono Framework MDK ${MONO_VER}/MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.pkg" -target /
+ - wget "http://download.mono-project.com/archive/${MONO_VER}/macos-10-x86/MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.pkg" "http://download.mono-project.com/archive/${MONO_VER}/macos-10-x86/MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.dmg" || true
+ - hdid "MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.dmg" || true
+ - sudo installer -pkg "/Volumes/Mono Framework MDK ${MONO_VER}/MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.pkg" -target / || true
+ - sudo installer -pkg "MonoFramework-MDK-${MONO_VER}.macos10.xamarin.x86.pkg" -target / || true
+ - xbuild /p:Configuration=Release || true
script:
- xbuild /p:Configuration=Release
Please sign in to comment.
Something went wrong with that request. Please try again.