[SDL] Do not attempt to use versions < 2.0.0 #126

Merged
merged 2 commits into from May 31, 2014

Conversation

Projects
None yet
1 participant
Contributor

thefiddler commented May 30, 2014

Versions prior to 2.0.0 are not ABI-compatible with 2.0.x and
attempting to use those will result in random instability. We now
explicitly check the SDL2 version before enabling the SDL2 backend.

thefiddler added some commits May 30, 2014

@thefiddler thefiddler [SDL] Do not attempt to use versions < 2.0.0
Versions prior to 2.0.0 are not ABI-compatible with 2.0.x and
attempting to use those will result in random instability. We now
explicitly check the SDL2 version before enabling the SDL2 backend.
7153a69
@thefiddler thefiddler [SDL] Removed unnecessary if-branch 897c4d7

@thefiddler thefiddler added a commit that referenced this pull request May 31, 2014

@thefiddler thefiddler Merge pull request #126 from thefiddler/sdlversion
[SDL] Do not attempt to use versions < 2.0.0
08829c4

@thefiddler thefiddler merged commit 08829c4 into opentk:develop May 31, 2014

1 check passed

continuous-integration/travis-ci The Travis CI build passed
Details

thefiddler deleted the thefiddler:sdlversion branch May 31, 2014

thefiddler added this to the 1.1.3 milestone Jun 20, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment