@msach22 msach22 released this Oct 5, 2018 · 1 commit to master since this release

Assets 3

Adds the following APIs

  • Set Stream Class Lists
  • Initial Layout Class Token
  • Set Archive Layout

Improves documenation

@msach22 msach22 released this Aug 13, 2018 · 26 commits to master since this release

Assets 3

Add forceDisconnect documentation and tests
Add signaling API
Add getStream API
Add listStreams API
Add filtration by sessionId for listArchives (thanks @magroski)

@msach22 msach22 released this Jun 2, 2018 · 29 commits to master since this release

Assets 3

Fixes startArchive for individual stream archiving

@msach22 msach22 released this Jun 1, 2018 · 31 commits to master since this release

Assets 3

Adds resolution parameter to startArchive feature

@aiham aiham released this Feb 9, 2018 · 46 commits to master since this release

Assets 3

This is the alpha release of OpenTok PHP SDK v4. It primarily features the upgrade of the guzzle dependency from guzzle3 to guzzlehttp6. Although the API does not change in this version, the change has affected every method and has a chance to break SDK users in subtle and unexpected ways which is why the major version number has been incremented.

#132 - Move to Guzzle 6 (#201)

Please use this chance to test your applications and report if you find any problems. If there are no glaring issues the final v4.0.0 will be released in 1 week time.

@aiham aiham released this Feb 6, 2018 · 59 commits to master since this release

Assets 3
  • Make run-demo script work in PHP7 (#199)
  • Fix typo: horizontalPresentaton -> horizontalPresentation (#200)

@aiham aiham released this Oct 16, 2017 · 63 commits to master since this release

Assets 3
  • Add from support on SIP calls (#193, #196)

@aiham aiham released this Jun 30, 2017 · 68 commits to master since this release

Assets 3

This release brings along full PHP 7 support and increases our minimum PHP version to 5.6 which aligns with PHP's own support schedule: http://php.net/supported-versions.php

Because of this change we've decided to bump the major version to 3 to respect semver.

We can now increase our dependency versions, particularly phpunit which was necessary to run our tests in PHP 7.

Unfortunately we have not been able to upgrade our version of guzzle yet, see #132

Thanks for using OpenTok-PHP-SDK

@aiham aiham released this Jun 30, 2017 · 75 commits to master since this release

Assets 3

#187 Don't parse 204 No Content responses because of a change in PHP 7's json_decode()

This will be the final version that supports PHP 5.3, 5.4 and 5.5.

Although this version should work with PHP 7 you may have issues with incompatible dependencies such as phpunit which require a lower PHP version. The next version will be v3 and will have complete support for PHP 7.