Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#438 - ar7xx: missing/unknown modules #5534

Closed
openwrt-bot opened this issue Jan 27, 2017 · 4 comments
Closed

FS#438 - ar7xx: missing/unknown modules #5534

openwrt-bot opened this issue Jan 27, 2017 · 4 comments
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Jan 27, 2017

mgondium:

LEDE snapshot r3176-82d580e8b5 on TPLINK 710Nv1 (ar7xx/ath9k)

Log messages about missing/unknown modules, without obvious fault in functionality.

Using ledtrig-netdev:
daemon.err modprobe: failed to find a module named netdev-br-lan
daemon.err modprobe: failed to find a module named netdev-tun0
daemon.err modprobe: failed to find a module named netdev-

When loading luci-qos:
daemon.err modprobe: failed to find a module named sch_fq_codel
daemon.err modprobe: failed to find a module named xt_CONNMARK

When firmware is compiled without IPv6 support:
daemon.err modprobe: failed to find a module named net-pf-10

Regarding this, openvpn-openssl fails to load without IPv6 kernel support if proto is "udp" (has to be "udp4"):
daemon.warn openvpn: Could not determine IPv4/IPv6 protocol. Using AF_INET6
daemon.err openvpn: UDP: Cannot create UDP/UDP6 socket: Address family not supported by protocol (errno=124)

Cheers.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Feb 2, 2017

bolvan:

try "iw aaaaaa" and logread.
modprobe process is called directly by kernel and only if "iw" was run under root. I replaced kmodloader (modprobe is linked to it) with bash script to print $PPID and it was kworker process

It looks like dirty kernel hack or misbehaving feature in openwrt environment

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Feb 3, 2017

yousong:

The issue should be now fixed with commit "c26ff034fce0fe4770e1a33d44841aae6d418862: ubox: support quiet modprobe, support millisecond log timestamp accuracy"

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Feb 3, 2017

mgondium:

@bolvan:
that produced a "daemon.err modprobe: failed to find a module named netdev-aaaaaa", so I guess
you are right.

Now running r3285-1a52d11d38 with luci-qos,ledtrig-netdev and no IPv6.
Bootup shows (logread | grep -i fail):

Fri Feb 3 14:21:45 2017 daemon.err modprobe: failed to find a module named sch_fq_codel
Fri Feb 3 14:21:46 2017 daemon.err modprobe: failed to find a module named xt_CONNMARK
Fri Feb 3 14:21:51 2017 daemon.err modprobe: failed to find a module named sch_fq_codel
Fri Feb 3 14:21:52 2017 daemon.err modprobe: failed to find a module named xt_CONNMARK
Fri Feb 3 14:24:12 2017 daemon.err modprobe: failed to find a module named sch_fq_codel
Fri Feb 3 14:24:18 2017 daemon.err dnsmasq[1775]: failed to send packet: Operation not permitted
Fri Feb 3 14:24:18 2017 daemon.err dnsmasq[1775]: failed to send packet: Operation not permitted
Fri Feb 3 14:24:18 2017 daemon.err dnsmasq[1775]: failed to send packet: Operation not permitted
Fri Feb 3 14:24:18 2017 daemon.err dnsmasq[1775]: failed to send packet: Operation not permitted

The first part is from qos. lsmod shows no codel scheduler loaded but there is a xt_connmark (no capitals). The standalone script (/usr/lib/qos/generate.sh all | sh) shows no errors even using fq_codel, so I guess all if fine.

The second part is new and reloading dnsmasq logs no error, so it's probably a race condition (the "no-IPv6" can of worms?)

The netdev- messages are gone.

Cheers.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Feb 15, 2017

nbd:

Fixed in r3498-40374454f9

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant