Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#597 - Unchecking "Use DNS servers advertised by peer" has no effect for IPv6 #5618

Closed
openwrt-bot opened this issue Mar 5, 2017 · 3 comments
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Mar 5, 2017

Typhoon31:

Hi everyone,

When the option "Use DNS servers advertised by peer" has been unchecked, LEDE still writes the advertised peer DNS Servers for v6 into /tmp/resolv.conf.auto:

Interface wan

Interface wan_6

nameserver xxx
nameserver xxx

The IPv4 nameservers just disappear in this file, and on the overview page, these two v6 DNS Servers still appear on the "network" section (without their v4 counterparts).

To actually force dnsmasq to ignore these two, I have to check "Ignore resolve file" in the dnsmasq configuration.

I'm running LuCI lede-17.01 branch (git-17.051.53299-a100738) / LEDE Reboot 17.01.0-rc2 r3131-42f3c1f on a Linksys 1900ACS v2.

My WAN connection is a PPPoE connection with "Use builtin IPv6-management" checked and the option below set to "automatic".

@openwrt-bot
Copy link
Author

openwrt-bot commented Mar 6, 2017

jow-:

I staged a proposed fix at https://git.lede-project.org/0cd002a and asked dedeckeh to help testing it.

@openwrt-bot
Copy link
Author

openwrt-bot commented Mar 7, 2017

dedeckeh:

Confirmation Jow's patch fixes the issue

@openwrt-bot
Copy link
Author

openwrt-bot commented Mar 7, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant