Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#755 - [SUNXI] ImageBuilder fails because of kmod-eeprom-sunxi #5735

Closed
openwrt-bot opened this issue May 3, 2017 · 1 comment
Closed
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented May 3, 2017

nemesisdesign:

soc: sunxi
LEDE 17.01.1

How to reproduce:

  • clone lede source
  • checkout to 17.01 branch
  • configure a build with sunxi target (i'm trying with Lomobo R1)
  • compile imagebuilder
  • extract imagebuilder
  • try to generate images

The imagebuilder will fail, complaining that kmod-eeprom-sunxi is missing.

Looking for this module in make menuconfig, I found:

Depends on: TARGET_sunxi [=y] && !LINUX_4_4 [=y]

It seems it doesn't want the Kernel 4.4 but according to more devs this doesn't make much sense, hence a cleanup would be desirable.

@openwrt-bot
Copy link
Author

openwrt-bot commented May 3, 2017

nemesisdesign:

Launching the image builder with the following flags works:

make image PROFILE="DEVICE_sun7i-a20-lamobo-r1" PACKAGES="-kmod-eeprom-sunxi"

I have tested the resulting image, which seems to work fine

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant