Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1123 - base-files: os-release: HOME_URL not settable / set to LEDE_DEVICE_MANUFACTURER_URL #5781

Closed
openwrt-bot opened this issue Oct 28, 2017 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Oct 28, 2017

chris5560:

Device independent
LEDE 17.01.4 and LEDE r5201-8b9cdebc9c

Set
-> Image configuration
-> Version configuration options
-> Manufacturer URL
to a non-empty value and build

Problem:

  • HOME_URL set to LEDE_DEVICE_MANUFACTURER_URL
  • HOME_URL is nowhere settable inside “make menuconfig”
  • If Manufacturer URL is cleared, HOME_URL still set after rebuild
@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 1, 2018

yousong:

LEDE_DEVICE_xxx vars should be device-specific instead of being a global option. I guess the option was previously introduced for oem users. As such setting HOME_URL also to LEDE_DEVICE_MANUFACTURER_URL with a default value of upstream homepage makes sense.

I cannot reproduce the 3rd issue about LEDE_DEVICE_MANUFACTURER_URL and HOME_URL not being in sync. It works as expected here.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant