Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1179 - scripts/feeds does not install package mc #6143

Closed
openwrt-bot opened this issue Nov 20, 2017 · 1 comment
Closed

FS#1179 - scripts/feeds does not install package mc #6143

openwrt-bot opened this issue Nov 20, 2017 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Nov 20, 2017

val-kulkov:

Something odd is happening. Package "mc" is not detected by "make menuconfig" and is not installed by "scripts/feeds install mc".

Steps to reproduce:

git clone https://git.lede-project.org/source.git
scripts/feeds update -a
$ ls -l feeds/packages/utils/mc
total 12
-rw-rw-r-- 1 val val 1614 Nov 19 18:34 Config.in
-rw-rw-r-- 1 val val 3103 Nov 19 18:34 Makefile
drwxrwxr-x 2 val val 4096 Nov 19 18:34 patches

Now,

scripts/feeds install -a

A symlink for package "mc" in package/feeds/packages/ is not created. "make menuconfig" does not see package "mc" at all:

$ ls -l package/feeds/packages/mc ls: cannot access 'package/feeds/packages/mc': No such file or directory

The issue is observed on LEDE HEAD as of the time of this writing: bc50a97

This is bizarre.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Nov 29, 2017

thess:

The root of the problem is that there is a package named //mc// in the core packages (added as part of //NXP layerscape// platform on Oct 16). As it stands now, core packages always take precedence over community packages. Perhaps the layerscape management package should be differently named.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant